On dash Brake Light
+ Reply to Thread
Results 1 to 4 of 4

This is a discussion on On dash Brake Light within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; Recently started this past week in my 04 wrx. Brake light stays on after taking off my Parking break. No ...

  1. #1
    Registered User corybb's Avatar
    Join Date
    Aug 2007
    Location
    Cape Girardeau, MO
    Posts
    240

    On dash Brake Light

    Recently started this past week in my 04 wrx.
    Brake light stays on after taking off my Parking break.
    No rubbing. No noise. Brake is definitely disengaged.

    After like the 1st minute of driving, it will turn off at a stop, but turns back on once the car reaches 15-20 mph or often in between 1st/2nd gear shift.

    Later in the day or after extended driving, the light never comes on.

    On a side note, my parking brake has never felt very "strong" it often has trouble holding car on an incline (reverse especially). I always have to park with it in gear.

    Any Ideas?

    I've read some about fluid levels, or possibly needing new pads/rotors?

    It seems once brake or possibly fluid heats up the issue goes away. I checked and I dont THINK the fluid levels are down.

    ???

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User EvoEatr's Avatar
    Join Date
    Aug 2008
    Location
    Kennett Square, Pennsylvania
    Posts
    1,839
    Be sure about the fluid level before we go further..I would make sure the reservoir is full..after that I would be checking the switch by the e-brake...

  4. #3
    Registered User corybb's Avatar
    Join Date
    Aug 2007
    Location
    Cape Girardeau, MO
    Posts
    240
    switch? like a sensor?

  5. #4
    Registered User jrswrx69's Avatar
    Join Date
    Sep 2008
    Location
    powell tn
    Posts
    121
    Quote Originally Posted by EvoEatr View Post
    Be sure about the fluid level before we go further..I would make sure the reservoir is full..after that I would be checking the switch by the e-brake...
    its a switch that at the back to the ebrake assembly under the console it could have a loose connection or sticks as for the brakes no wanting to hold if pads are like new there is an adjustment for the ebrake right there under the console as well at least in the 02-03 and 06-07 models

+ Reply to Thread

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself. We strongly suggest that you stay away from using aol, yahoo, msn, and hotmail accounts. Sometimes the mail server blocks the emails from our server. As a result you will not receive any notifications including the confirmation email.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •