P0103 help
+ Reply to Thread
Results 1 to 7 of 7

This is a discussion on P0103 help within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; My car feels like its hitting fuel cut at 4500 rpm then once its past it pulls hard again. A ...

  1. #1
    Registered User wrxwagon2's Avatar
    Join Date
    Feb 2009
    Location
    allentown,pennsylvania
    Posts
    226

    P0103 help

    My car feels like its hitting fuel cut at 4500 rpm then once its past it pulls hard again. A check engine light came on and i scanned it with my AP and i got p0103 high input on my MAF. Any suggestions on where to start would be appreciated, Thanks.
    2004 WRX (currently driving)
    2000 Audi S4 APR tuned (sold)
    2002 WRX wagon ( sold )
    1988 Thunderbird Turbocoupe

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Moderator Donkey's Avatar
    Join Date
    Apr 2005
    Location
    Da boonies
    Posts
    6,296
    I Support ClubWRX
    Whats your mods?
    Resident Adviser @ WTF Tuning, LLC
    2002 FORESTER S
    1998 FORESTER S




  4. #3
    Registered User wrxwagon2's Avatar
    Join Date
    Feb 2009
    Location
    allentown,pennsylvania
    Posts
    226
    SPT intake, Turboback exhaust, Cobb AP stage 2 93.
    2004 WRX (currently driving)
    2000 Audi S4 APR tuned (sold)
    2002 WRX wagon ( sold )
    1988 Thunderbird Turbocoupe

  5. #4
    Moderator Donkey's Avatar
    Join Date
    Apr 2005
    Location
    Da boonies
    Posts
    6,296
    I Support ClubWRX
    How long have you had the intake? Try cleaning the MAF and resetting the ECU.
    Resident Adviser @ WTF Tuning, LLC
    2002 FORESTER S
    1998 FORESTER S




  6. #5
    Registered User wrxwagon2's Avatar
    Join Date
    Feb 2009
    Location
    allentown,pennsylvania
    Posts
    226
    Just got the SPT intake, i replaced the MAF like three months ago, should i still try cleaning it?
    2004 WRX (currently driving)
    2000 Audi S4 APR tuned (sold)
    2002 WRX wagon ( sold )
    1988 Thunderbird Turbocoupe

  7. #6
    Moderator Donkey's Avatar
    Join Date
    Apr 2005
    Location
    Da boonies
    Posts
    6,296
    I Support ClubWRX
    The intake is probably causing the problem. Reset the ECU.
    Resident Adviser @ WTF Tuning, LLC
    2002 FORESTER S
    1998 FORESTER S




  8. #7
    Registered User wrxwagon2's Avatar
    Join Date
    Feb 2009
    Location
    allentown,pennsylvania
    Posts
    226
    I did reset reset the ECU still same problem. Why does the SPT intake cause this>?
    2004 WRX (currently driving)
    2000 Audi S4 APR tuned (sold)
    2002 WRX wagon ( sold )
    1988 Thunderbird Turbocoupe

+ Reply to Thread

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself. We strongly suggest that you stay away from using aol, yahoo, msn, and hotmail accounts. Sometimes the mail server blocks the emails from our server. As a result you will not receive any notifications including the confirmation email.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •