Some minor problems with my 09 WRX
Results 1 to 7 of 7

This is a discussion on Some minor problems with my 09 WRX within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; Ok so I have a brand new 2009 wrx sedan with navi and I have a couple problems wanted some ...

  1. #1
    Registered User
    Join Date
    Sep 2009
    Posts
    40

    Some minor problems with my 09 WRX

    Ok so I have a brand new 2009 wrx sedan with navi and I have a couple problems wanted some other people opinions. First off my radio reception kinda sucks sometimes it has a lot of static and sometimes it sounds good. Second in my navi options there is an option where you can set the map brightness to auto where it gets brighter or darker depending if your headlights are on and it doesnt change . And finally the last thing today me and my girlfriend were driving home and we both had our seat warmers on when I started to smell a burning smell almost like when you create a short I was just wondering is that just the seat warmers breaking in????

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    UnBanned Sinister's Avatar
    Join Date
    Nov 2006
    Location
    Denver Metro Area
    Posts
    17,628
    I Support ClubWRX
    Quote Originally Posted by 09WRXer View Post
    Ok so I have a brand new 2009 wrx sedan with navi and I have a couple problems wanted some other people opinions. First off my radio reception kinda sucks sometimes it has a lot of static and sometimes it sounds good. Second in my navi options there is an option where you can set the map brightness to auto where it gets brighter or darker depending if your headlights are on and it doesnt change . And finally the last thing today me and my girlfriend were driving home and we both had our seat warmers on when I started to smell a burning smell almost like when you create a short I was just wondering is that just the seat warmers breaking in????
    Do you have window tint?

    The brightness you have to adjust on each mode to see the difference.

    I'm not going to say one way or the other on the seat warmers, but if it's anything like an electric blanket, it doesn't sound like a big deal... May want to check w/ the dealership though... cover your ass, ya know?
    Kevin
    Moderator
    Sinister's Blowoff Valve FAQ
    WRX Gas Mileage FAQ
    Sinister's Progress Thread - 430whp 429wtq - Sold
    Firearms Enthusiasts Thread

    The Sheriff's Star at the bottom left corner rates a user's reputation.
    If you found a user's post to be helpful or quite the opposite, please make it known to them by clicking the Star!

  4. #3
    Registered User
    Join Date
    Sep 2009
    Posts
    40
    ok so I just figured out why the map wouldnt dim when the headlights are on you have to set your dimmer switch to one click from full brightness. So now I'm still wondering why I smelled an electrical burning smell when I had my seat warmers on??

  5. #4
    Registered User elwray's Avatar
    Join Date
    Nov 2008
    Location
    Central NJ
    Posts
    991
    Quote Originally Posted by Sinister View Post
    Do you have window tint?

    The brightness you have to adjust on each mode to see the difference.

    I'm not going to say one way or the other on the seat warmers, but if it's anything like an electric blanket, it doesn't sound like a big deal... May want to check w/ the dealership though... cover your ass, ya know?
    lol, pun intended?

    In all seriousness though, you should definitely get that checked out at the dealership.

    I bought my car in November I believe, and never had any smell from the seat warmers. But it may have already been "tested" by previous test drivers since it was already getting cold out. You bought the car in the summer so maybe nobody "tested" them yet and you're the first to burn off whatever is on them.

    But definitely take it to the dealership. The LAST thing you need is for the goddamn seat to catch on fire!!!!!
    2009 WRX Hatch PP Dark Gray Metallic
    Torqued Performance Stage 1
    Cobb CBE
    Kenwood DNX5120

  6. #5
    Registered User brbauer's Avatar
    Join Date
    Sep 2009
    Location
    White Marsh MD
    Posts
    184
    Yeah...unsure about the navi or radio (my radio is fine in my 09 wagon but don't have navi)

    As far as the seat warmers, go get that checked! I have turned mine on about twice now to see if they work and I have not smelt anything unusual. That sounds like an electrical problem and could be serious.

    good luck - let us know what it was whenever u figure it out!
    2009 WRX 5 door White - "wht out"
    1998 VW Passat 1.8T Black - blown engine
    1988 Porsche 944 Black - sold
    1999 Honda CBR 600 - sold

  7. #6
    Registered User
    Join Date
    Sep 2009
    Posts
    40
    The thing is the smell was only there for a secound and both sits seem to still work I was think is it possible that part of the seat warmer might of burned out. When you guys have your seat warmer on which parts of the seat feels warm if you place your hand on it??

  8. #7
    Registered User A265's Avatar
    Join Date
    Mar 2009
    Location
    in a igloo
    Posts
    763
    I got my car with 7KM and I didn't smell anything when I turned on the heated seats.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •