Throttle or boost issue
+ Reply to Thread
Results 1 to 3 of 3

This is a discussion on Throttle or boost issue within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; This happens only when im in 3rd or 4th gear, and im at wot and max boost. When I hit ...

  1. #1
    Registered User SharfElMasry's Avatar
    Join Date
    Dec 2008

    Throttle or boost issue

    This happens only when im in 3rd or 4th gear, and im at wot and max boost. When I hit 3000 rpm the engine revs very quickly (as if its in neutral) to about 4000rpm than back down to about 3200rpm and i continue acclerating. Also at the same time the boost goes down a bit while the engine revs, than picks up.

    There are no mods on the car. Im not sure if its anything to worry about, but it never happened before, and I just wanna understand why its happening.
    Thanks in advance for any help

  2. Remove Advertisements

  3. #2
    He simply abides. SD_GR's Avatar
    Join Date
    Jul 2002
    CA, US
    I Support ClubWRX
    It sounds like your clutch is slipping. If so you will need to replace the clutch.

    As the clutch fails to clamp during increased torque output from the motor, the revs climb but the car does not accelerate. The boost gauge drops when the clutch is slipping since the effective load on the motor also drops -- the driveline is not linked to the motor when the slip occurs.
    WRX Info Links, Courtesy TheJ
    Man is a brute.... If you're cruel to him, he respects and fears you. If you're kind to him, he plucks your eyes out. Alexis Zorbas
    I am at the moment writing a lengthy indictment against our century. When my brain begins to reel from my literary labors, I make an occasional cheese dip. Ignatius J. Reilly
    DISCLAIMER: Opinions expressed are the author's alone and are inherently worthless.

  4. #3
    Registered User wrxlaunch's Avatar
    Join Date
    Apr 2008
    Clutch going out
    VF-43 Bugeye: OPEN SOURCE tune... 121xxx miles

    13.1@105... Lazy launch 1.9 60'
    285whp and 300WTQ.

+ Reply to Thread

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself. We strongly suggest that you stay away from using aol, yahoo, msn, and hotmail accounts. Sometimes the mail server blocks the emails from our server. As a result you will not receive any notifications including the confirmation email.

Please select your insurance company (Optional)


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts