2003 wrx grind between 4th to 5th gear.
Results 1 to 2 of 2

This is a discussion on 2003 wrx grind between 4th to 5th gear. within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; Hello fellow subaru owner, Is been bugging me for sometime now , whenever I enter the free way going from ...

  1. #1
    Registered User
    Join Date
    Jan 2008
    Location
    mn
    Posts
    36

    2003 wrx grind between 4th to 5th gear.

    Hello fellow subaru owner,
    Is been bugging me for sometime now , whenever I enter the free
    way going from 40mph to 65mph shifting to 5th gear it would grind, shifting into reverse have becoming rather troublesome too,
    the only mods thats done to this car is...

    SPT CAI w/heat shield
    TBE
    cobb ap stage 1
    cobb adjustable s/shifter.

    everything still stock,

    I'm not sure whats going on , but my best bet is that i'm gonna need a new tranny/clutch work.

    Can anyone tell me what is the exact cause of this symptom.

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User spatwinturbo's Avatar
    Join Date
    Oct 2009
    Location
    Dallas, TX
    Posts
    27
    Quote Originally Posted by guy_in_red_wrx View Post
    Hello fellow subaru owner,
    Is been bugging me for sometime now , whenever I enter the free
    way going from 40mph to 65mph shifting to 5th gear it would grind, shifting into reverse have becoming rather troublesome too,
    the only mods thats done to this car is...

    SPT CAI w/heat shield
    TBE
    cobb ap stage 1
    cobb adjustable s/shifter.

    everything still stock,

    I'm not sure whats going on , but my best bet is that i'm gonna need a new tranny/clutch work.

    Can anyone tell me what is the exact cause of this symptom.
    Same problem here, i tryed changin the trainy fluid with mobil and still did it, so i went with castrol and it still does it... it goes in smoothly in 5th gear only when i wait 2 seconds with the clutch pressed in.

    help please

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •