Whirlling sound
Results 1 to 7 of 7

This is a discussion on Whirlling sound within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; Installed big topmount ic makes high pitch sound.have stock turbo, sounds like intake anyone know what it might be???...

  1. #1
    Registered User
    Join Date
    Sep 2009
    Location
    olympia wa
    Posts
    27

    Question Whirlling sound

    Installed big topmount ic makes high pitch sound.have stock turbo, sounds like intake anyone know what it might be???

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Banned
    Join Date
    Dec 2003
    Location
    Dallas, TX / Sterling, VA
    Posts
    6,629
    I Support ClubWRX
    You have an air leak. Tighten the clamps and your bypass valve bolts.

  4. #3
    Registered User
    Join Date
    Jan 2008
    Location
    Nebraska
    Posts
    681
    It might not be an air leak. Whirring makes me think turbo. I noticed that as well when i switched to a spearco TMIC. It seemed as though i could hear the turbo spooling better. Keep in mind this wasn't a large difference. How loud is the noise? Does it run well? At what RPM and load do you hear this noise?

    As brfatal said, check your clamps and all your flange bolts.

  5. #4
    Registered User
    Join Date
    Sep 2009
    Location
    olympia wa
    Posts
    27
    Ask buddy of mine he said maybe more air movin could cause it but don't I tried tightinghose off turbo put silicon on bypass

  6. #5
    Banned
    Join Date
    Dec 2003
    Location
    Dallas, TX / Sterling, VA
    Posts
    6,629
    I Support ClubWRX
    Did you use hairspray on the silicon? Did you use a new bypass valve gasket?

  7. #6
    Registered User
    Join Date
    Sep 2009
    Location
    olympia wa
    Posts
    27
    The noise is when I get on the gas I seem to be getting same boost level as before install of tmic

  8. #7
    Registered User
    Join Date
    Sep 2009
    Location
    olympia wa
    Posts
    27
    Didn't use new gasket just silicon

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •