Oil on the turbine blades? :(
Results 1 to 6 of 6

This is a discussion on Oil on the turbine blades? :( within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; I just bought a used TD04 and got to taking a look at it, and it has an oil residue ...

  1. #1
    Registered User
    Join Date
    Jan 2008
    Location
    Nebraska
    Posts
    681

    Oil on the turbine blades? :(

    I just bought a used TD04 and got to taking a look at it, and it has an oil residue on the turbine blades and housing. I can't imagine this is a good thing.

    The TD04 i just pulled off my car (100k miles) has no oil whatsoever on any part of the turbine housing/wheel. Bone dry. Of coursie it has the standard black carbon deposits, but other than that, dry.

    I was going to replace my high mileage TD04 with this newer one (30k miles) since mine was starting to eat coolant a little and whine a lot. What do you guys think? Are there any non-dead turbo reasons why there might be so much oil residue on the blades and housing?

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User JUSTINSNUTSWINGER's Avatar
    Join Date
    Jul 2008
    Location
    San Antonio
    Posts
    1,923
    A little from blow-by..... Snap a pic.
    N-swinger

    2000 Escort

    Maintenance schedule and poke in the eyes:
    http://www.clubwrx.net/forums/genera...nce-guide.html

  4. #3
    Registered User EvoEatr's Avatar
    Join Date
    Aug 2008
    Location
    Kennett Square, Pennsylvania
    Posts
    1,839
    +1^

  5. #4
    Admiral Ackbar the 1st mycologist's Avatar
    Join Date
    Oct 2005
    Location
    Late Devonian
    Posts
    13,029
    I Support ClubWRX
    Or maybe the motor blew up.
    "From a little spark may burst a mighty flame." - Dante
    "The stitch is lost unless the thread is knotted." - Italian proverb

  6. #5
    Registered User
    Join Date
    Jan 2008
    Location
    Nebraska
    Posts
    681
    from what the guy on nasioc told me, it was ran at stock power levels until ~30k, then swapped for a bigger turbo.

    I'll try to get some pics up later. Its just a light coating of oil residue over everything. Turbine blades, the nut, the housing immediately around the turbine wheel. A light coating, but heavy enough that the blades look wet in appearance compared to the perfectly dry blades of my current stock turbo.

    I doubt its blow by. It would have to be the inverse of blowby. Like blow-suck ha. Blow-by pushes the oil out the crankcase vents, back into the intake tract. It shouldn't touch the hotside though.

  7. #6
    Registered User JUSTINSNUTSWINGER's Avatar
    Join Date
    Jul 2008
    Location
    San Antonio
    Posts
    1,923
    What color is the oil ? Black or redish ? What are the chances it could have been from an over oiled filter combined with blow by.

    If not check the seals.... 30K blown td04 ? Not likely. And he said he ran stock boost ?
    N-swinger

    2000 Escort

    Maintenance schedule and poke in the eyes:
    http://www.clubwrx.net/forums/genera...nce-guide.html

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •