99 wrx - Page 2
Page 2 of 2 FirstFirst 12
Results 16 to 21 of 21

This is a discussion on 99 wrx within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; Originally Posted by konejjo like the forum police dude said That's why the forum cop got all mad and said ...

  1. #16
    Sammich Makin' Pwincess wrxtreme06's Avatar
    Join Date
    May 2007
    Location
    orlando flawduh
    Posts
    12,504
    I Support ClubWRX
    Quote Originally Posted by konejjo View Post
    like the forum police dude said
    That's why the forum cop got all mad and said I hijacked your thread.
    he actually is a moderator & its his job to make sure the forum rules are being kept.

    rule number 3: no threadjacking
    ClubWRX Forum - Subaru Impreza WRX and STi Community and Forums - FAQ

    desiree
    your friendly, neighborhood subaru girl
    abbigale : 06 impreza wrx tr: cobb stage II
    hawkeye alliance #11:11//
    wingl3ss @ll!ance #17 // lvl 80 N.E.R.D.

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #17
    Registered User
    Join Date
    Aug 2009
    Posts
    7

    Didnt realise

    Quote Originally Posted by konejjo View Post
    Hey Adam , like the forum police dude said my prob might be different. It's almost the same but with my prob I think The tune went bad. Cuz I switch everything back to stock and no more jerks. The bcs is a boost control solenoid. When you get a custom tune. You can get a prodrive with 3 nipples it enables you to get a lil more boost. So I had to change mine to revert to stock!! That's why the forum cop got all mad and said I hijacked your thread. I'm sorry don't throw me to jail!!!lol. Mine didn't jerk when down shifting just when crusing then I gave it some gas around 2500 rpm it would jerk then it got up and went. What cel are you getting Adam ?? Cuz I didn't even get one!!
    No cel either....
    The car was fine today? But when im cruisin it just looses power and then when i try to excelerate the jerking starts. Then when i downshift and excelerate the same thing, theres just no drive either. Its like its flooded or an electrical short. Just buried down, if that makes sense. Have it booked in next week so if we find the prob will let u no. But what you say about the bcs (thanks) is worth checking out. Also have been told by a friend to check my distributer as it may be playing up. How much boost you running on a regular day to day?

  4. #18
    Registered User konejjo's Avatar
    Join Date
    Aug 2008
    Location
    redondo beach ca
    Posts
    9
    Hey Adam I don't wanna confuse you or anything but have you ever thought that mabey your experiencing chatter. I don't know ?? How long have you had your clutch for. It's worth looking at. Let me know what they told you please!!!

  5. #19
    Registered User
    Join Date
    Aug 2009
    Posts
    7
    Quote Originally Posted by konejjo View Post
    Hey Adam I don't wanna confuse you or anything but have you ever thought that mabey your experiencing chatter. I don't know ?? How long have you had your clutch for. It's worth looking at. Let me know what they told you please!!!
    Cool will let you no as soon as i do.
    Will talk to my mechanic about the clutch, but its sti and only done 30000 and it still fells really good. There dosnt seem to be even any prob with friction points. Dont no! Thanks for your help, much appreciated!

  6. #20
    Admiral Ackbar mycologist's Avatar
    Join Date
    Oct 2005
    Location
    Late Devonian
    Posts
    12,420
    I Support ClubWRX
    Quote Originally Posted by Adam Walters View Post
    No cel either....
    The car was fine today? But when im cruisin it just looses power and then when i try to excelerate the jerking starts. Then when i downshift and excelerate the same thing, theres just no drive either. Its like its flooded or an electrical short. Just buried down, if that makes sense. Have it booked in next week so if we find the prob will let u no. But what you say about the bcs (thanks) is worth checking out. Also have been told by a friend to check my distributer as it may be playing up. How much boost you running on a regular day to day?
    I would start by replacing the fuel filter and cleaning the MAF - you can do this yourself if you like. If you can test the fuel pressure. I assume the air filter is new and that the filter box is closed correctly (this is not uncommon at all, look carefully at the bottom tabs). The car doesn't have an actual distributor, it has coil packs attached to each spark plug. One or more could be bad.

    Now that EvoEtr knows you don't have a cel maybe he can help more than I.... He is an actual Subaru tech.
    "From a little spark may burst a mighty flame." - Dante
    "The stitch is lost unless the thread is knotted." - Italian proverb

  7. #21
    Registered User konejjo's Avatar
    Join Date
    Aug 2008
    Location
    redondo beach ca
    Posts
    9
    Hey Adam did you find out what went wrong?? Cuz min is doing it again! I'm gonna check the ignition coils. But does any one know how to check them. And also looking at fuel filter the sti you need to buy the whole fuelpump assembely sux cuz I just bought the walbro fp!! Hit me up thanx

Page 2 of 2 FirstFirst 12

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •