CEL help
+ Reply to Thread
Page 1 of 2 12 LastLast
Results 1 to 15 of 16

This is a discussion on CEL help within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; Thanks for reading, I'm new to subarus, I just bought a 04 wrx two months ago and love it. The ...

  1. #1
    Registered User
    Join Date
    Aug 2009
    Posts
    12

    CEL help

    Thanks for reading, I'm new to subarus, I just bought a 04 wrx two months ago and love it. The other night I was cruising around 50mph and my CEL came on. Next day I went to Autozone and had it scanned, P0420. (Catalyst System Efficiency Below Threshold (Bank 1). I then found out what this code could be by looking on google. I dropped off the car at a mechanic to have it checked out. It will be looked at on monday (8/17).

    The current mods are:
    K&N typhoon intake
    Perrin uppipe
    TurboXS TBE with high flow cat
    Magnaflow exhaust
    ECUtec reflash
    (91,000K)


    is the rear 02 sensor bad? it seems that after an aftermarket exhaust/cat and a good tune with these mods, it would be the sensor rather than a bad cat? Can i run with the sensor unplugged and just have the light reset? ANY help is appreciated!

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User Sunkist's Avatar
    Join Date
    Mar 2002
    Location
    Tucson, AZ
    Posts
    216
    It is prob your high flow cat, I got this CEL when I switched from stock to a 3" catted downpipe, it would come and go randomly. You can drive fine with it on and it is a little strange that you have a reflash and are still getting it since usually the reflash turns the CEL off (mine did).
    My woman hates the money pit
    2002 WRX Hybrid 2.5L 16G

  4. #3
    Registered User
    Join Date
    Aug 2009
    Posts
    12
    thanks for the reply, so if this CEL becomes a reacurrance, how do I go about turning the light off? thanks again!

  5. #4
    Registered User Sunkist's Avatar
    Join Date
    Mar 2002
    Location
    Tucson, AZ
    Posts
    216
    Either get your tuner to reflash you and disable the code or do a CEL fix, there are several ways, do a search on here or NASIOC to find how. I did a mechanical fix when I got the downpipe and I still got the CEL periodically.
    My woman hates the money pit
    2002 WRX Hybrid 2.5L 16G

  6. #5
    Registered User
    Join Date
    Aug 2009
    Posts
    12
    Thanks for the replys, so if I get the rear 02 sensor replaced and this CEL comes back up, I can just ignore it? and it will eventually turn off? will it hurt my engine to drive with it on? sorry about all the questions, I'm just really worried about it

  7. #6
    Registered User Sunkist's Avatar
    Join Date
    Mar 2002
    Location
    Tucson, AZ
    Posts
    216
    You shouldn't need to replace the sensor, it just sees more gas (gases?) in your emissions that the high flow cat is not cleaning out compared to how stock did. The CEL does not mean your car is going to have problems so it is okay to drive with it and mine would go away after 100 miles or so and then pop up again later on. I would still get that CEL blocked by a reflash so it does not keep popping up just in case you have to do emissions testing or if another CEL comes you will know it is not this one just popping up again.
    My woman hates the money pit
    2002 WRX Hybrid 2.5L 16G

  8. #7
    Registered User
    Join Date
    Aug 2009
    Posts
    12
    Okay, the mechanic called and says my cat off the manifold is bad. He is going to order a Subaru OEM stock cat. Said the light will be off after that. What do you think? Kinda makes me wonder why the rear 02 sensor would pick something up like that.. wouldn't the front 02 be the one reporting a bad cat?
    Last edited by plumma125; 08-19-2009 at 07:51 PM.

  9. #8
    Registered User Sunkist's Avatar
    Join Date
    Mar 2002
    Location
    Tucson, AZ
    Posts
    216
    So your cat in the downpipe is bad? I would just get a new downpipe then, you don't want a OEM cat when you should have a high flow cat instead. The rear sensor reads the levels after the cat so it would show if something was wrong.
    My woman hates the money pit
    2002 WRX Hybrid 2.5L 16G

  10. #9
    Registered User
    Join Date
    Aug 2009
    Posts
    12
    I guess its the "pre cat" thats getting replaced.. a $400 dollar Subaru made only part..

  11. #10
    Registered User Sunkist's Avatar
    Join Date
    Mar 2002
    Location
    Tucson, AZ
    Posts
    216
    Pre-cat? You may want to check exactly what is getting done before you pay $400 for a part you may not need (from Subaru anyway). I honestly have no idea what that is though.
    My woman hates the money pit
    2002 WRX Hybrid 2.5L 16G

  12. #11
    Registered User Spencer3636's Avatar
    Join Date
    Apr 2009
    Location
    No-Town
    Posts
    8
    Quote Originally Posted by plumma125 View Post
    I guess its the "pre cat" thats getting replaced.. a $400 dollar Subaru made only part..
    It sounds like he is talking about your up-pipe since that comes off your exhaust manifold and I would not pay $400 for an up pipe with a cat in it. The catted uppipe can prove problematic just being there. That's why the newer WRX's and all the STI's don't even have that cat.

    I think he is implying that he wants to remover your cattless UPP and put in the stock clunker, and I'm sure he will try to charge tons for the install since he will need to either remove the turbo or raise the block to change it out.
    Last edited by Spencer3636; 08-20-2009 at 10:13 AM.
    Carpe Diem!

    My 03 Bugeye is cooler than your mom

    Bugeye Mafia #222

  13. #12
    Registered User Sunkist's Avatar
    Join Date
    Mar 2002
    Location
    Tucson, AZ
    Posts
    216
    Quote Originally Posted by Spencer3636 View Post
    It sounds like he is talking about your up-pipe. and I would not pay $400 for an up pipe with a cat in it. The catted uppipe can prove problematic just being there. That's why the newer WRX's and all the STI's don't even have that cat.

    hmmm you did say Perrin uppipe.. I think the mechanic is pullin on you. only cat's in stock WRX are Up pipe and two in the down pipe.
    I was thinking up pipe too except that he has the Perrin, he needs to find out what exactly the mechanic is getting him
    My woman hates the money pit
    2002 WRX Hybrid 2.5L 16G

  14. #13
    Registered User Spencer3636's Avatar
    Join Date
    Apr 2009
    Location
    No-Town
    Posts
    8
    Quote Originally Posted by Sunkist View Post
    I was thinking up pipe too except that he has the Perrin, he needs to find out what exactly the mechanic is getting him
    yea, I fixed my post, I really think the mechanic wants to put a stocker back in, I'm sure that would stop the light, but if that is the case the o2 fix you mentioned earlier would be best, that or the tune through.

    Gotta love mechanics!
    Carpe Diem!

    My 03 Bugeye is cooler than your mom

    Bugeye Mafia #222

  15. #14
    Registered User
    Join Date
    Aug 2009
    Posts
    12
    Okay I just got the car back, the mechanic replaced what looks like a home-made/exhaust shop uppipe. It was catless. I guess I didn't have a perrin upper.. So they put the stock uppipe back in. I'm glad the car is back with no CEL, and I took it for a 45min test drive and it performed good. I can tell a bit of hp loss but its not really noticable once I'm in peak rpms..

    Is the stock pipe a bad choice? I'm not a peak performance guru, I just want whats best for the life of my ride. Thanks again for all your help people!

  16. #15
    Registered User Sunkist's Avatar
    Join Date
    Mar 2002
    Location
    Tucson, AZ
    Posts
    216
    The two major prob with the stock up-pipe are restrictive causing a loss of HP and if/when the cat goes it will take out your turbo too. I say get a new/used catless up-pipe and then get a tune to disable the CEL (if you are tuned already I am surprised you were getting a CEL in the first place).
    My woman hates the money pit
    2002 WRX Hybrid 2.5L 16G

+ Reply to Thread
Page 1 of 2 12 LastLast

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself. We strongly suggest that you stay away from using aol, yahoo, msn, and hotmail accounts. Sometimes the mail server blocks the emails from our server. As a result you will not receive any notifications including the confirmation email.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •