brand new 16g turbo with no boost
Results 1 to 5 of 5

This is a discussion on brand new 16g turbo with no boost within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; I installed a brand new blouche 16g td05 on my 03 wrx today and I'm getting no boost at all. ...

  1. #1
    Registered User
    Join Date
    Dec 2008
    Posts
    6

    brand new 16g turbo with no boost

    I installed a brand new blouche 16g td05 on my 03 wrx today and I'm getting no boost at all. I have checked all the connections and hoses but none of them seem loose. Does it require an aftermarket controller?
    Thanks in advance.

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Admiral Ackbar mycologist's Avatar
    Join Date
    Oct 2005
    Location
    Late Devonian
    Posts
    12,773
    I Support ClubWRX
    Quote Originally Posted by krrawn View Post
    I installed a brand new blouche 16g td05 on my 03 wrx today and I'm getting no boost at all. I have checked all the connections and hoses but none of them seem loose. Does it require an aftermarket controller?
    Thanks in advance.
    What other mods do you have? What kind of DP? Did you install injectors and tune for the new injectors/turbo? Or install/adjust anything else like a BOV? It doesn't require a controller but you have to get tuned for it.

    Still should be hitting some boost though, at least the actuator spring pressure even if the lines aren't right. How are you measuring boost? Is your BOV or BPV stuck open? Is your wastegate stuck open somehow?

    Sorry for all the questions, but it will help a lot.
    "From a little spark may burst a mighty flame." - Dante
    "The stitch is lost unless the thread is knotted." - Italian proverb

  4. #3
    Registered User
    Join Date
    Dec 2008
    Posts
    6
    I have electric cutout exhaust, turbo xs topmount turbo xs short ram intake, walbro 255, up pipe down pipe and tuned to run with those. I am waiting to install the new injectors because i dont want to have a broader range of problems to diagnose at one time. And as an update it is boosting (wich i didnt realize at first post) really late 4500 rpms.

  5. #4
    Admiral Ackbar mycologist's Avatar
    Join Date
    Oct 2005
    Location
    Late Devonian
    Posts
    12,773
    I Support ClubWRX
    Quote Originally Posted by krrawn View Post
    I have electric cutout exhaust, turbo xs topmount turbo xs short ram intake, walbro 255, up pipe down pipe and tuned to run with those. I am waiting to install the new injectors because i dont want to have a broader range of problems to diagnose at one time. And as an update it is boosting (wich i didnt realize at first post) really late 4500 rpms.
    It is really no surprise then. Put the injectors in and get it tuned then go from there.
    "From a little spark may burst a mighty flame." - Dante
    "The stitch is lost unless the thread is knotted." - Italian proverb

  6. #5
    Banned
    Join Date
    Dec 2003
    Location
    Dallas, TX / Sterling, VA
    Posts
    6,629
    I Support ClubWRX
    Quote Originally Posted by krrawn View Post
    I have electric cutout exhaust, turbo xs topmount turbo xs short ram intake, walbro 255, up pipe down pipe and tuned to run with those. I am waiting to install the new injectors because i dont want to have a broader range of problems to diagnose at one time. And as an update it is boosting (wich i didnt realize at first post) really late 4500 rpms.
    Wait, you're driving 4500 rpms without injectors or tuning?

    :unamused:

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •