Tail Lights won't turn on when I turn on headlights
Results 1 to 3 of 3

This is a discussion on Tail Lights won't turn on when I turn on headlights within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; I've got a problem with turning on my rear tail lights. I've got a 2004 WRX Wagon. When I turn ...

  1. #1
    Registered User
    Join Date
    Jul 2009
    Posts
    1

    Tail Lights won't turn on when I turn on headlights

    I've got a problem with turning on my rear tail lights. I've got a 2004 WRX Wagon.

    When I turn on my headlights, my tail lights should turn on but they don't. They do however come on when I brake. I've replaced the fuses and the bulbs and all looks fine. Both the right and the left tail light respond the same (they only turn on when I brake). Any ideas?

    Thanks

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User vttk_mig69's Avatar
    Join Date
    Jan 2008
    Location
    Sheboygan, WI
    Posts
    527
    relay or ground would be my next guess.

  4. #3
    Registered User EvoEatr's Avatar
    Join Date
    Aug 2008
    Location
    Kennett Square, Pennsylvania
    Posts
    1,839
    check the virgin switch on top of the steering column ive seen these get caught in the middle position (between on and off) before and cause some odd issues...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •