Help a newb out plz!
Results 1 to 4 of 4

This is a discussion on Help a newb out plz! within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; After I got my head rebuilt because of 4 bent valves, the car ran fine. Now after about 5 miles, ...

  1. #1
    Registered User ej20_allday's Avatar
    Join Date
    Apr 2009
    Location
    Chi-town
    Posts
    91

    Help a newb out plz!

    After I got my head rebuilt because of 4 bent valves, the car ran fine. Now after about 5 miles, the car just suddenly started smoke white out of the exhaust. It happened while idling in my drive way. I can smell coolant and I checked my oil, doesn't look like it burnt any but I'm not 100% sure. I can still start the car and it will idle but like I said, the revs jump and it smokes A LOT. I'm hoping its just a seal but I don't kno because my mechanic won't be able to come check it out for another week! BTW, its a 2005 WRX.
    I keep my scooby clean

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User EvoEatr's Avatar
    Join Date
    Aug 2008
    Location
    Kennett Square, Pennsylvania
    Posts
    1,839
    How did you bend the valves? T-belt jump/break? I would bring it right back to the tech/shop who worked on it...did he pull the engine to do the work? Was there any other damage done to any of the other internals? If he had the cyl. head off than it could be a multitude of things...Im hoping this was a knowledgeable tech who adjusted the valves and did the job properly...Nonetheless I would bring the car right back to the shop who worked on it...

  4. #3
    Registered User ej20_allday's Avatar
    Join Date
    Apr 2009
    Location
    Chi-town
    Posts
    91
    I bought the car crashed off an auto auction, the t belt was off so I though all I needed to do is replace it a set the timing. But I guess it was off for too long and my engine had four bent valves. The guy who worked on it is a subaru and mazda tech, I'll have him check it out but I was hoping someone might know wats wrong.
    I keep my scooby clean

  5. #4
    Registered User EvoEatr's Avatar
    Join Date
    Aug 2008
    Location
    Kennett Square, Pennsylvania
    Posts
    1,839
    All I can say I guess is if you car is burning coolant im suspecting either a HG issue or a turbo issue...I will say this it is somewhat rare for Subaru HG's to leak internally...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •