AC Smell & Squeaky Pedal
Results 1 to 6 of 6

This is a discussion on AC Smell & Squeaky Pedal within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; I have just about 7,000 miles on my 09 WRX Wagon and there are few items that's started to become ...

  1. #1
    Registered User
    Join Date
    Dec 2008
    Posts
    7

    AC Smell & Squeaky Pedal

    I have just about 7,000 miles on my 09 WRX Wagon and there are few items that's started to become slightly annoying. Nothing horrible, but I'm hoping there are easy remedies for each. I tried searching but found various posts from earlier Subaru vehicles... none of them really seemed to apply to what I've been experiencing.

    Problem #1: The AC has an extremely odd smell when operating, especially during the morning drive to work. It's kind of a semi-sweet, dry, chemical smell that I was hoping would go away but it hasn't. It started from day 1 of ownership.... I'm going to try the water / bleach (3:1) spray into the intake but does anyone else have any suggestions on why this is happening?

    Problem #2: The clutch pedal has a distinct metallic click when I push the pedal in during the first two inches of travel. It doesn't happen all the time though, so it comes and goes. It's pretty loud during certain parts of the drive and I can quickly push the clutch pedal in / out of the first two inches feeling a notch (sensor switch?) and hearing the audible click once the pedal hits it.

    Problem #3: I hate rattles. They annoy the crap out of me with any car I've had and I'll tear the entire dash apart to find it. There's a pretty consistent rattle inside the dash on top of the radio unit about 6 inches before the windshield. Anyone else?

    If anyone has some tips I'd greatly appreciate it.

    -ct

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User EvoEatr's Avatar
    Join Date
    Aug 2008
    Location
    Kennett Square, Pennsylvania
    Posts
    1,839
    With 7,000 miles on the vehicle and it being an 09' model, before you mess with anything I would bring it to the dealer and have them address the problems...IF they cant find anything wrong than I would go do what you want to try and locate the problems ( I say this because if you go messing with things and than bring it in they can/might say the warranty was voided or something)...That being said... #1 : For the AC problem you could try and evaporator cleaning kit ( our dealership just started selling them)...Is it like a musty smell? Does it smell like coolant? Is it only when the AC is on, not just the vents? #2: chances are the noise you are hearing is a clutch switch of sorts engaging (this is an oddly common problem I notice with a lot of Subaru's) does the clutch/ all related components operate normally to your knowledge? #3: do you have an i-pod interface in the vehicle? has anyone ever had the radio out or anything to maybe install a dealer option or something?.... I will say this again it is very difficult to help diagnose noises online fore we cannot hear/see/touch the vehicle...just mentioning it

  4. #3
    Registered User
    Join Date
    Dec 2008
    Posts
    7
    Thanks for the feedback.

    #1: Yes I guess it has a similar scent like engine coolant. It only kicks in when the AC compressor is engaged. If the fan is running while recirculating or taking in fresh air, it's fine.

    #2: Yeah the clutch has been behaving as I would expect it should.

    #3: To my knowledge no one should of been in the dash since the factory. Nothing was added beyond the STI short throw kit that was pre-installed when I purchased my WRX.

    I think the suggestion of bringing it to the dealer is the route I'll take this time. That reminds me I'll hit them up for a free oil change while it's there.

    Thanks!

  5. #4
    Registered User EvoEatr's Avatar
    Join Date
    Aug 2008
    Location
    Kennett Square, Pennsylvania
    Posts
    1,839
    no problem man..let me know what they find Im kind of interested we don't really get THAT many problems with such a new Subie...

  6. #5
    Registered User
    Join Date
    Dec 2008
    Posts
    7
    Oh yes that reminds me of the last bugger I forgot to mention.

    Is there anything the dealer can do to smooth out the fueling right around 3200 - 3300 rpms (1st / 2nd gear) while under normal driving conditions? If I'm light on the throttle it has a noticeable lurch / hessitation... I'm thinking it's got something to do with the fuel mapping that it got from the factory.

  7. #6
    Registered User EvoEatr's Avatar
    Join Date
    Aug 2008
    Location
    Kennett Square, Pennsylvania
    Posts
    1,839
    wow..I mean you can always bring it up to them of course if this is an obvious like jerking twisting motion of the vehicle than they might look into it...lol..are you sure it isnt just a little turbo-lag? Of course you can always download Romraider and throw in your own custom fueling MAP....do so at your own risk..

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •