Think I made an oops!
+ Reply to Thread
Results 1 to 5 of 5

This is a discussion on Think I made an oops! within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; So about a month ago i swapped out my uppipe with a catless one and replaced my exhaust with one ...

  1. #1
    Registered User CJ05's Avatar
    Join Date
    Apr 2008
    Location
    North Juarez Mexico (aka El Paso TX)
    Posts
    1,178

    Think I made an oops!

    So about a month ago i swapped out my uppipe with a catless one and replaced my exhaust with one from an STi. During the process i completely removed the turbo (kinda had to to get the uppipe out) anyways, i got everything put back in and forgot to reclamp the oil return line that runs directly underneath the turbo. The metal line is completely seated inside the rubber hose and it is clamped on the bottom but not on the top. Could this be an issue or should i be good to go? Reason i am asking is that my oil was low when i checked it this morning.
    Bugeye Mafia #231 - 2002 WRB - sold Dec 31, 2009
    -Stink-Eye Mob- #173 - 2008 SWP - Returned to TD04 Stage 2 in Jan 2012
    Frmr Blobeye Syndicate #173 - 2005 CGM -sold Sept 15, 2008. I miss my STi
    Proud owner of 99 RS coupe with EJ205 engine and tranny swap.

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User Pavia's Avatar
    Join Date
    Dec 2006
    Location
    Philly/DE area
    Posts
    2,934
    Your not losing oil from it, but you need to properly clamp all lines. Go ahead and recheck your oil level after 5-10 mins of run time. If it's below the low mark, add some oil.
    06 GTO M6 Quicksilver, SLP 455 Bobcat, LS7 Clutch w/ SS line (RPM tune:373rwhp/373rwtq)
    07 WRX TR M5 Garnet Red Pearl w/ Straight PPGs and Cusco front LSD (Agile tune:307whp/343wtq)

  4. #3
    Registered User EvoEatr's Avatar
    Join Date
    Aug 2008
    Location
    Kennett Square, Pennsylvania
    Posts
    1,839
    I would def. go back and double check that line..just to make sure its not leaking...OH FWIW...next time you put an up pipe on one of these 2.5 or 2.0 Turbo cars...you can install the up pipe without pulling the Turbo...Just undo the two 14mm's for the motor mounts and the two 14mm for the dogbone and jack the motor up a bit...I think its a hell of alot easier...

  5. #4
    Registered User 2:43AM's Avatar
    Join Date
    Sep 2008
    Location
    NWI
    Posts
    647
    Quote Originally Posted by EvoEatr View Post
    I would def. go back and double check that line..just to make sure its not leaking...OH FWIW...next time you put an up pipe on one of these 2.5 or 2.0 Turbo cars...you can install the up pipe without pulling the Turbo...Just undo the two 14mm's for the motor mounts and the two 14mm for the dogbone and jack the motor up a bit...I think its a hell of alot easier...
    Just one nut, on the passenger side mount, and jack up 2 inches. Cake walk.

  6. #5
    Registered User CJ05's Avatar
    Join Date
    Apr 2008
    Location
    North Juarez Mexico (aka El Paso TX)
    Posts
    1,178
    I checked it and it's not leaking oil...plus when i checked my oil later that evening after adding about 3/4 of a quart my oil level is not high. Both times the car was checked hot so there shouldn't be any discrepancy between the two readings.
    Bugeye Mafia #231 - 2002 WRB - sold Dec 31, 2009
    -Stink-Eye Mob- #173 - 2008 SWP - Returned to TD04 Stage 2 in Jan 2012
    Frmr Blobeye Syndicate #173 - 2005 CGM -sold Sept 15, 2008. I miss my STi
    Proud owner of 99 RS coupe with EJ205 engine and tranny swap.

+ Reply to Thread

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself. We strongly suggest that you stay away from using aol, yahoo, msn, and hotmail accounts. Sometimes the mail server blocks the emails from our server. As a result you will not receive any notifications including the confirmation email.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •