AC problem! HELP!!!
Results 1 to 4 of 4

This is a discussion on AC problem! HELP!!! within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; ok so I went on a subaru drive here in oregon.... my air condition was working fine all the way ...

  1. #1
    Registered User
    Join Date
    Apr 2009
    Posts
    71

    AC problem! HELP!!!

    ok so I went on a subaru drive here in oregon....

    my air condition was working fine all the way there and most of the way back... and then for some reason it started cutting out but then came back on and lasted the whole way back home.....

    i then washed the car and went to park it in the garage and notice my AC wasnt on again and it wont turn on... my AC compressor i can hear turn off and on so that is cycling... i know the air is getting cold because i can have it on and drive with the vents on and can feel the air a little.

    I have checked all fuses inside the car and outside in the engine bay. Also tested the Relays theres 2 Ones black and ones blue behind the glove box.

    heres the parts:
    left one is black right one is blue... (2523079972) and (2523079971) both made by nissan.

    Napa's part numbers same as the nissan ones above.
    Blue : 25230-9B900 @ napa is was 18.50
    Black: 25230-79982 @ napa it was 11.50

    I guess the black one is actually for your headlights and im not sure what the blue one is....and i hope these are the right relays that im looking for...

    anyone have any clue what could cause this issue? all my controls light up and when i move the dials i can see them moving the vents in the back of the glove box.....

    I tested both the blue and the black relays out of another 05 and they it didnt help and they seem to be working so its either some kind of wiring or the blower that is not working.

    if its the Blower is it a hard install? and price??

    any help thanks all!

    exdakine@yahoo.com

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    He simply abides. SD_GR's Avatar
    Join Date
    Jul 2002
    Location
    CA, US
    Posts
    22,220
    I Support ClubWRX
    Quote Originally Posted by exdakine View Post
    my air condition was working fine all the way there and most of the way back... and then for some reason it started cutting out but then came back on and lasted the whole way back home.....
    What is "it?" The A/C? The blower motor?

    i know the air is getting cold because i can have it on and drive with the vents on and can feel the air a little.
    This implies "it" above is the blower motor.

    anyone have any clue what could cause this issue?
    The blower switch or blower motor.

    if its the Blower is it a hard install?
    A/C Compressor problems...

    I am assuming you do not hear the blower motor spinning when you do not get air flow. If you do hear the motor spinning, start by removing the glovebox and checking if the filter is clogged or if you do not have a filter, if there is an obstruction. If you hear no fan noise, see above but in your case it could be a loose harness clip since you hear nothing at all, or a switch problem.

    and price??
    Priceless. Consider a used unit from a wrecked car (plenty of wrecked WRXs...). Or contact subaruparts.com or another online vendor for a new unit and pricing.
    WRX Info Links, Courtesy TheJ
    The world breaks everyone and afterward many are strong in the broken places. Ernest Hemingway
    I lied. I cheated. I bribed men to cover the crimes of other men. I am an accessory to murder. But the most damning thing of all... I think I can live with it. And if I had to do it all over again - I would. Benjamin Sisko
    DISCLAIMER: Opinions expressed are the author's alone and are inherently worthless.

  4. #3
    Registered User
    Join Date
    Apr 2009
    Posts
    71
    No I do not hear the motor spinning at all and I already have the glovebox removed currently. and I can see that its not spinning the filter is clean.

    The compressor is kicking on and off when I turn the AC on.

    I'm thinking its the Blower motor... so hopefully I can figure out how to change this out my self.

    The blower switch? you mean the control gauge?

    how do I see if that's the issue?

  5. #4
    He simply abides. SD_GR's Avatar
    Join Date
    Jul 2002
    Location
    CA, US
    Posts
    22,220
    I Support ClubWRX
    You can test the switch with a multimeter, it seems to be a stepped attenuator. Check the link I provided for access to the manuals for blower removal.
    WRX Info Links, Courtesy TheJ
    The world breaks everyone and afterward many are strong in the broken places. Ernest Hemingway
    I lied. I cheated. I bribed men to cover the crimes of other men. I am an accessory to murder. But the most damning thing of all... I think I can live with it. And if I had to do it all over again - I would. Benjamin Sisko
    DISCLAIMER: Opinions expressed are the author's alone and are inherently worthless.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •