02 Bugeye with an issue
+ Reply to Thread
Results 1 to 7 of 7

This is a discussion on 02 Bugeye with an issue within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; Help. As the title states I have an issue with my bugeye. At idle the RPM's spike to 2200 RPM ...

  1. #1
    Registered User
    Join Date
    May 2009
    Location
    Richmond, Texas
    Posts
    5

    02 Bugeye with an issue

    Help. As the title states I have an issue with my bugeye. At idle the RPM's spike to 2200 RPM and drops back to 1000 RPM, Back to 2200 RPM, drops to 1000 RPM. Once I put the car in drive it runs like a spotted monkey and shows no signs of the spike but in the driveway, stop lights, etc she spikes. I have around 89k miles on her and the car was parked for about 2 months due to a knee injury. My question is, is the spike due to the car being parked for an extended period of time and will pass when driven, or do I have an issue. I am not asking for a miracle just some good advice. I now without seeing the car there is no way to tell for sure. Thanks for the read and an advice.

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User
    Join Date
    Oct 2008
    Location
    Corona
    Posts
    27
    here is a link to how to clean your idle control valve, maybe thats the problem. If you choose to do this make sure to have an extra gasket. Cleaning And Reattaching The IACV (Idle Air Control Valve) - NASIOC

  4. #3
    Registered User Spencer3636's Avatar
    Join Date
    Apr 2009
    Location
    No-Town
    Posts
    8
    "Your Vehicle(s)
    02 WRX,
    Estimated HP
    300 HP
    Engine/Transmission mods
    Down Pipe, Header, SGort Ram Intake"

    Do you use any kind of engine management?
    Carpe Diem!

    My 03 Bugeye is cooler than your mom

    Bugeye Mafia #222

  5. #4
    Registered User
    Join Date
    May 2009
    Location
    Richmond, Texas
    Posts
    5
    Quote Originally Posted by Spencer3636 View Post
    "Your Vehicle(s)
    02 WRX,
    Estimated HP
    300 HP
    Engine/Transmission mods
    Down Pipe, Header, Short Ram Intake"

    Do you use any kind of engine management?
    Nope, everything that is installed was there when I bought her and I have had her for a year

  6. #5
    Registered User Spencer3636's Avatar
    Join Date
    Apr 2009
    Location
    No-Town
    Posts
    8
    Quote Originally Posted by DannyG View Post
    Nope, everything that is installed was there when I bought her and I have had her for a year
    Do you have any CEL's kicking on? A good ol ECU reset could do the trick. Disconnect negative battery cable, hold down bake pedal for 30 seconds, reconnect, then start her up.
    Carpe Diem!

    My 03 Bugeye is cooler than your mom

    Bugeye Mafia #222

  7. #6
    Registered User
    Join Date
    May 2009
    Location
    Richmond, Texas
    Posts
    5
    Quote Originally Posted by Spencer3636 View Post
    Do you have any CEL's kicking on? A good ol ECU reset could do the trick. Disconnect negative battery cable, hold down bake pedal for 30 seconds, reconnect, then start her up.
    Dang sure will try this first. Thanks

  8. #7
    Registered User
    Join Date
    May 2009
    Location
    Richmond, Texas
    Posts
    5
    Quote Originally Posted by WRX504 View Post
    here is a link to how to clean your idle control valve, maybe thats the problem. If you choose to do this make sure to have an extra gasket. Cleaning And Reattaching The IACV (Idle Air Control Valve) - NASIOC
    This will be second on my list. Thanks for the advice.

+ Reply to Thread

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself. We strongly suggest that you stay away from using aol, yahoo, msn, and hotmail accounts. Sometimes the mail server blocks the emails from our server. As a result you will not receive any notifications including the confirmation email.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •