Need help figuring out this problem, please!!!!!!!!!
Results 1 to 12 of 12

This is a discussion on Need help figuring out this problem, please!!!!!!!!! within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; Today I did a compression test and results are NOT GOOD!!! -the left side of engine was fine(cylinders 2,4) at ...

  1. #1
    Registered User BlueEvoEater's Avatar
    Join Date
    Oct 2007
    Location
    Naples, FL
    Posts
    15

    Question Need help figuring out this problem, please!!!!!!!!!

    Today I did a compression test and results are NOT GOOD!!!
    -the left side of engine was fine(cylinders 2,4) at 160 lbs each
    -but the right side, cylinder 1, was at 80 lbs and cylinder 3 at 165lbs, which is fine.
    -I noticed the condition on the outside of the right side of the engine(cylinders 1,3) was a lot dirtier, like with oil and dirt, BUT the left side was clean as a whistle...I'm wondering if it might be the headgasket because I'm sure it couldn't be the rings yet nor valves. What do you all think it could be??? My car is burning oil too...during cold start-up and once warm you rev it a little, there is whitish-bluish smoke from the exhaust then it stops once it has warmed up. I would appreciate your help THANKS!!!

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User EvoEatr's Avatar
    Join Date
    Aug 2008
    Location
    Kennett Square, Pennsylvania
    Posts
    1,839
    How many miles are on the vehicle? What year? like 90% of Subaru HG's that fail leak externally and mostly its the drivers side and you will never burn oil or coolant...well at least noticeably...Personally I would try a wet compression test and a leakdown test...and see what you get from those...This should really narrow things down....You said the smoke is mostly white or blue? You said the smoke stops when you are completely warmed up...That kind of sounds like a ring problem to me....but try those tests and we'll see what we get....
    Last edited by EvoEatr; 05-16-2009 at 05:47 PM.

  4. #3
    Registered User BlueEvoEater's Avatar
    Join Date
    Oct 2007
    Location
    Naples, FL
    Posts
    15
    it is a 2004 with about 52,000 miles...the side that has the cylinder problem is the passenger side but the reason why i think it is the HG is that the outside of the head was caked with dirt and oil while the other side(driver's side) was not...and i do notice significant oil loss within a month

  5. #4
    Registered User EvoEatr's Avatar
    Join Date
    Aug 2008
    Location
    Kennett Square, Pennsylvania
    Posts
    1,839
    And It might very well be a HG problem...however with 52k miles and me personally seeing like 1 or 2 Turbo Subarus in the past with a HG problem compared to the thousands of NA Subarus with HG problems Personally I find it unlikely....Give those tests a whirl and we'll be able to tell more... Of course you could always try chemical combustion leak test also of the coolant fore you said your seeing some white smoke... Has this car been raced/launched beat etc etc?? Is the dirt/oil on the head near the front or the back? You dont want to go throwing HG's on when it could be a ring/valve problem...
    Last edited by EvoEatr; 05-17-2009 at 05:26 AM.

  6. #5
    Registered User BlueEvoEater's Avatar
    Join Date
    Oct 2007
    Location
    Naples, FL
    Posts
    15
    Yes i was racing this car before at the strip(about 20 passes in all this car has been on the track) and i was launching at redline(rev limiter) everytime. i have been at 22 psi on stock turbo during those runs and daily driving since i've had the car(sep. 2007). The dirt was on top of the head, on the side and i'm sure on the bottom too but i didn't check...i will not be doing any work until i find out exactly where it is. I am going to do that leak down test that u said..

  7. #6
    Registered User BlueEvoEater's Avatar
    Join Date
    Oct 2007
    Location
    Naples, FL
    Posts
    15
    Do you know if that HG leak repair liquid works or not???

  8. #7
    Registered User EvoEatr's Avatar
    Join Date
    Aug 2008
    Location
    Kennett Square, Pennsylvania
    Posts
    1,839
    Yikes 22PSI on the stock turbo...jesus...thats some serious pressure...So the car has been run pretty hard..um yeah try the wet compression test also see what you get there...Ive seen these cars crack ring lands also so that might be a possibility...As for the HG coolant conditioner that only works if there is a coolant leak, you cant/shouldnt add it to the oil...are you sure you dont have another oil leak or something....thats kind of odd that the entire head around the gasket area is covered....Of course you could always take some brakekleen and clean off the entire thing and pop back under there in a few days to see whats up...

  9. #8
    Moderator Donkey's Avatar
    Join Date
    Apr 2005
    Location
    Da boonies
    Posts
    5,994
    I Support ClubWRX
    Quote Originally Posted by BlueEvoEater View Post
    i was launching at redline(rev limiter) everytime. i have been at 22 psi on stock turbo during those runs
    Found your problem.........
    Resident Adviser @ WTF Tuning, LLC
    2002 FORESTER S
    1998 FORESTER S




  10. #9
    Registered User BlueEvoEater's Avatar
    Join Date
    Oct 2007
    Location
    Naples, FL
    Posts
    15
    Quote Originally Posted by Donkey View Post
    Found your problem.........
    HAHAHAHA...yea but i couldn't resist, i was doing 8.52's in the 1/8 mile and now i'm paying the price but whatever, you can't get away just increasing power without replacing parts right...

  11. #10
    Registered User BlueEvoEater's Avatar
    Join Date
    Oct 2007
    Location
    Naples, FL
    Posts
    15
    Quote Originally Posted by EvoEatr View Post
    Yikes 22PSI on the stock turbo...jesus...thats some serious pressure...So the car has been run pretty hard..um yeah try the wet compression test also see what you get there...Ive seen these cars crack ring lands also so that might be a possibility...As for the HG coolant conditioner that only works if there is a coolant leak, you cant/shouldnt add it to the oil...are you sure you dont have another oil leak or something....thats kind of odd that the entire head around the gasket area is covered....Of course you could always take some brakekleen and clean off the entire thing and pop back under there in a few days to see whats up...
    OK...i'm going to try what u just told me and see how it does...THANKS for your comments i really appreciate it thanks a bunch!!!!

  12. #11
    Registered User EvoEatr's Avatar
    Join Date
    Aug 2008
    Location
    Kennett Square, Pennsylvania
    Posts
    1,839
    no prob. man...let us know how it goes...

  13. #12
    Moderator Donkey's Avatar
    Join Date
    Apr 2005
    Location
    Da boonies
    Posts
    5,994
    I Support ClubWRX
    Quote Originally Posted by BlueEvoEater View Post
    HAHAHAHA...yea but i couldn't resist, i was doing 8.52's in the 1/8 mile and now i'm paying the price but whatever, you can't get away just increasing power without replacing parts right...
    Try launching at 5k.
    Resident Adviser @ WTF Tuning, LLC
    2002 FORESTER S
    1998 FORESTER S




Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •