O2 sensor
Results 1 to 5 of 5

This is a discussion on O2 sensor within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; Hello. my check engine light came on and i had it tested and the code was for a rear 02 ...

  1. #1
    Registered User
    Join Date
    Jul 2008
    Posts
    49

    O2 sensor

    Hello. my check engine light came on and i had it tested and the code was for a rear 02 sensor. any suggestions on which one to get? i heard to stay away from the universal ones but idn what the difference is and when i look them up i see them listed as before cat converter but i havnt seen any saying after cat.
    Also..... when driving, if i accelerate and let off the gas, the bov makes the whoosh sound. but lately it has been making a stuttering whoosh. i cant tell if it is the bov making the stuttering or if its coming from somewhere else. is it a side effect of the sensor gone bad? iv asked alot of people and no one has a straight answer. any ideas on what i should test or inspect are greatly appreciated....

    Thanks Everyone!!!

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    DUB
    DUB is offline
    Registered User DUB's Avatar
    Join Date
    Jul 2007
    Location
    SLT, CA
    Posts
    3,176
    Get the sensor that is specifically for your vehicle. Any brand. The difference between that and a universal one is that it will plug right in to the existing wiring. The universal one will require you to wire it up by hand.

    As for the BOV, are we talking about an aftermarket unit? Or stock?

  4. #3
    Registered User
    Join Date
    Jul 2008
    Posts
    49
    It is an after market recirculating bov. Sry for not saying that at first.

  5. #4
    Registered User
    Join Date
    Jul 2008
    Posts
    49
    Its an aftermarket recirculating bov. Sry for not mentioning it earlier

  6. #5
    DUB
    DUB is offline
    Registered User DUB's Avatar
    Join Date
    Jul 2007
    Location
    SLT, CA
    Posts
    3,176
    My only idea is that the spring has come out of adjustment. It needs to be set up properly or it will "blow off" before it's supposed to.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •