my brakes
Results 1 to 3 of 3

This is a discussion on my brakes within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; hi there, i have a blobeye wrx sti - i have this strange problem with my car. when ever i ...

  1. #1
    zed
    zed is offline
    Registered User
    Join Date
    Mar 2009
    Posts
    17

    my brakes

    hi there,

    i have a blobeye wrx sti - i have this strange problem with my car. when ever i drive fast my brake pedal goes hard but as soon as I'm back to normal speed it becomes normal.

    can anyone guide me in the right direction and tell me what i will need to do?

    thanks
    zed

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Moderator Donkey's Avatar
    Join Date
    Apr 2005
    Location
    Da boonies
    Posts
    6,104
    I Support ClubWRX
    Sounds like maybe the brake booster is going bad or the oone way valve in the vacuum house is malfunctioning.I would try buying a new hose from the dealership and replacing the old one and see what happens.The one way valve is actually a plastic cylinder inside the hose.
    Resident Adviser @ WTF Tuning, LLC
    2002 FORESTER S
    1998 FORESTER S




  4. #3
    zed
    zed is offline
    Registered User
    Join Date
    Mar 2009
    Posts
    17
    thanks for the reply m8, how much will these part cost me? do you have a part no.?

    thanks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •