knock sensor code
+ Reply to Thread
Results 1 to 6 of 6

This is a discussion on knock sensor code within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; Hi, I have a 1994 jdm wrx, car runs well, pretty clean, when engine gets hot, maybe 30min and more ...

  1. #1
    Registered User
    Join Date
    Apr 2009
    Posts
    11

    knock sensor code

    Hi,


    I have a 1994 jdm wrx, car runs well, pretty clean, when engine gets hot, maybe 30min and more i may have a check engine with the knock sensor code... and then i gets into protective mode, i guess cuz it wont let me boost, if i had some serious problem, would i hear something not good before the 30 min of running?

    Does it mean my knock sensor gets some incoherant readings when engine is hot, or that there is something wrong with my combistion or anything ... plz help

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User EvoEatr's Avatar
    Join Date
    Aug 2008
    Location
    Kennett Square, Pennsylvania
    Posts
    1,839
    If your getting a code for your knock sensor than there is something wrong with either the sensor itself or the wiring...usually its a bad sensor...The older ones at least on the USDM model legacies and imprezas the knock sensor has a tendency to crack...on the face of it (where it mates to the block)...What code is in the car? How many miles?..Do you hear any knocking or anything?

  4. #3
    Registered User
    Join Date
    Apr 2009
    Posts
    11
    its code 22, i have 70 000km, but cant tell its real, i cant hear any serious knocking not too sure about light knocking tho, im new to the subaru mechanic, engine idle is steady and boosts at 11psi when on normal mode, then after a ride, often on a stop or red light, check engine will apear, but then still cant hear anything anormal, except if i try to boost, it wont let me.

    Im not sure where is the sensor itself, i think its under the intercooler.

  5. #4
    Registered User EvoEatr's Avatar
    Join Date
    Aug 2008
    Location
    Kennett Square, Pennsylvania
    Posts
    1,839
    On the USDM cars its on the Drivers side (left hand side) kind of right behind the #4 intake runner on the engine itself..you should be able to remove the intercooler and look straight down back there and see it..there should be one wire going to it...

  6. #5
    Registered User
    Join Date
    Apr 2009
    Posts
    11
    thx bro, here it is, the body is broken







  7. #6
    Registered User EvoEatr's Avatar
    Join Date
    Aug 2008
    Location
    Kennett Square, Pennsylvania
    Posts
    1,839
    no prob man...thats a pretty big crack...like i said when these Subie knock sensors fail they usually crack right along the side which mates to the engine block...

+ Reply to Thread

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself. We strongly suggest that you stay away from using aol, yahoo, msn, and hotmail accounts. Sometimes the mail server blocks the emails from our server. As a result you will not receive any notifications including the confirmation email.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •