Whitish smoke
Results 1 to 7 of 7

This is a discussion on Whitish smoke within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; hi guys i have a problem with my wrx, its a 98 model, bought it around 2 months ago, it ...

  1. #1
    Registered User mick's Avatar
    Join Date
    Apr 2009
    Location
    Brisbane
    Posts
    3

    Whitish smoke

    hi guys

    i have a problem with my wrx, its a 98 model, bought it around 2 months ago, it was runing fine, i gave it a bit here nd there as u do when u first get a car to test it out and everything seemed fine, but lately for about 2 weeks its been pouring out a whitish smoke, but it only hapens when the car is re started after turned off. when i first start it off in the morning it doesnt do it but when i turn it off and start it up again in around 30 minutes or so it poors out this whitish smoke for about 3 seconds and stops but the smell is a burning rubberish smell, the oil level keeps droping slowly, but when i re top it it doesnt seem to do it for a while, i got told it might be turbo or engine, but the guy just rebuilt it 15000ks ago, it has forged pistons and vf34 turbo, when i give it a bit it doesnt sound or feel like a mechanical problem, can anyone help??

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User Replay's Avatar
    Join Date
    Oct 2008
    Posts
    19
    Hows the coolant level?

  4. #3
    Registered User mick's Avatar
    Join Date
    Apr 2009
    Location
    Brisbane
    Posts
    3
    its pretty low man, there is a cap that you open it says do not open when hot im pretty sure thats the coolant from the radiator its got pipes going to the turbo its low and the colour is red, in the coolant area (where you fill it up) its past the low i just checked it and the colour is red, im bit newbie with mechanical side of cars, so im guessing it needs a flush, pressure test?

  5. #4
    Registered User Replay's Avatar
    Join Date
    Oct 2008
    Posts
    19
    haha well you are right on that aspect, I would flush out your coolant with some cleaner, and then pressure test...

  6. #5
    Registered User mick's Avatar
    Join Date
    Apr 2009
    Location
    Brisbane
    Posts
    3
    could bad coolant b why its smoking tho nd the reason why the oil level is dropping? its getting chekd by subary on wednesday and they rekon it might be a piston or the turbo might b gone....

  7. #6
    Registered User Replay's Avatar
    Join Date
    Oct 2008
    Posts
    19
    I don't see how a piston could be the problem the piston rings around the piston are for oil.... basically you know this, that coolant is leaking into the engine somehow and burning off. Most people would say that is a tell tale sign of a HG going out.... Though you should preform some other checks before the sube dealer. Pull out a plug, is it wet? How does the oil look? Is it discolored? the coloration of the coolant itself wouldn't be the problem but you should still flush it anyway.

  8. #7
    Registered User evoeater1985's Avatar
    Join Date
    Nov 2008
    Location
    highlands ranch colorado
    Posts
    38
    think about it..how would coolant get into you engine? turbo? Head gasket? i think you should take a look in those spots to see any problem other wise there shouldnt be any reason why coolant is in the engine. white smoke is one indication of a bad head gasket hope it isnt but maybe when he re built the engine he mite of done something wrong or some one did some thing wrong

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •