P0507 - Any suggestions? - Page 3
+ Reply to Thread
Page 3 of 3 FirstFirst 123
Results 31 to 35 of 35

This is a discussion on P0507 - Any suggestions? within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; Yeah..Its a tad tight in there..Sometimes i even have problems...and im on a lift...lol......

  1. #31
    Registered User EvoEatr's Avatar
    Join Date
    Aug 2008
    Location
    Kennett Square, Pennsylvania
    Posts
    1,839
    Yeah..Its a tad tight in there..Sometimes i even have problems...and im on a lift...lol...

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #32
    Registered User
    Join Date
    Aug 2010
    Posts
    3

    00 legacy outback p0507

    i was trying to do the seafoam treatment on my subaru so i took off the pcv valve hose nd pour like less than 5 ounces into the hose slowly of course with the engine running and all that but i think i did wrong either way because smoke never came out of the muffler and next day i check my car in auto zone with the scan tool and this code came out p0507 wich wasnt there before the only one i had was p0420 any ideas wat should i do? vochon@gmail.com

  4. #33
    Good news, everyone! xxxxxxxAnub1s's Avatar
    Join Date
    Jan 2005
    Location
    Eh, whaaaaa?
    Posts
    3,855
    I Support ClubWRX
    Are you sure you poured it into the correct hose? That code is for the IACV...
    Cody
    Hawk-Eye Alliance #727 N.E.R.D #255.255.255.0

    Your nighttime volunteer of near-useless information.
    Good news, everyone!

  5. #34
    Registered User
    Join Date
    Aug 2010
    Posts
    3

    heeeeeelp p0507

    i was trying to do the seafoam treatment on my subaru so i took off the pcv valve hose nd pour like less than 5 ounces into the hose slowly of course with the engine running and all that but i think i did wrong either way because smoke never came out of the muffler and next day i check my car in auto zone with the scan tool and this code came out p0507 wich wasnt there before the only one i had was p0420 any ideas wat should i do?


    Quote Originally Posted by Platinum13 View Post
    Hello all,

    My 1997 Impreza just started giving me a P0507 code and is idling really rough now.

    Any ideas on what I can try to fix/clean myself to correct this problem?

    Thanks.

  6. #35
    Registered User
    Join Date
    Aug 2010
    Posts
    3

    00 legacy outback p0507

    i poured it in the hose that connects right to the pcv valve you kno wich hose am talkin about? also when i wnt to autozone the info of the problable cause of the p0507 was faulty tps sensor or exhaust leak nd also something about dirty throttle body... i believe i dont remember very well...
    Quote Originally Posted by Anub1s View Post
    Are you sure you poured it into the correct hose? That code is for the IACV...

+ Reply to Thread
Page 3 of 3 FirstFirst 123

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself. We strongly suggest that you stay away from using aol, yahoo, msn, and hotmail accounts. Sometimes the mail server blocks the emails from our server. As a result you will not receive any notifications including the confirmation email.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •