P0457 ???
+ Reply to Thread
Results 1 to 5 of 5

This is a discussion on P0457 ??? within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; Hi, I have a 2002 WRX and the check engine light came on, I have a P0457 code, it is ...

  1. #1
    Registered User
    Join Date
    Feb 2009
    Posts
    13

    Red face P0457 ???

    Hi, I have a 2002 WRX and the check engine light came on, I have a P0457 code, it is about a large evap leak detected but I do not smell any gaz odor. I read on other forums that a reflash of the ecm at the dealer should fix the problem. Is it true ?

    Thank you

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Moderator Donkey's Avatar
    Join Date
    Apr 2005
    Location
    Da boonies
    Posts
    6,296
    I Support ClubWRX
    Quote Originally Posted by Lanthierwrx View Post
    Hi, I have a 2002 WRX and the check engine light came on, I have a P0457 code, it is about a large evap leak detected but I do not smell any gaz odor. I read on other forums that a reflash of the ecm at the dealer should fix the problem. Is it true ?

    Thank you
    Uhhmm....no.90% of the time it's because you did not tighten your gas cap properly or the gas cap is not sealing and needs to be replaced.The other 10% comes from people installing a turbo inlet and knocking loos one of the vacuum lines for the EVAP solenoid located on the manifold behind the alternator.Whoever suggested reflashing the ECM is a retard...........
    Resident Adviser @ WTF Tuning, LLC
    2002 FORESTER S
    1998 FORESTER S




  4. #3
    Registered User EvoEatr's Avatar
    Join Date
    Aug 2008
    Location
    Kennett Square, Pennsylvania
    Posts
    1,839
    +1^

  5. #4
    Registered User
    Join Date
    Feb 2009
    Posts
    13
    ok thanks for the answer, i do not ha a turbo inlet pipe, everything is stock so i'm going to check my gas cap to see if it seals properly

  6. #5
    Wrinklechops
    Did that fix the problem for you?

    I got this code tonight too.

    Some suggested the "charcoal canister" thing by the passenger side rear wheel well?

    Or it could be the rubber gasket seal on the pump assembly since I just swapped out the fuel filter yesterday...

    But boy does it smell like gas a lot in my car. lol

+ Reply to Thread

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself. We strongly suggest that you stay away from using aol, yahoo, msn, and hotmail accounts. Sometimes the mail server blocks the emails from our server. As a result you will not receive any notifications including the confirmation email.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •