Boost problem/mbc
Results 1 to 9 of 9

This is a discussion on Boost problem/mbc within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; I CANNOT GET OVER NINE POUNDS OF BOOST EVER.i have checked the vacuum lines the bcs and the restrictor pill ...

  1. #1
    Registered User
    Join Date
    Dec 2008
    Location
    puyallup
    Posts
    19

    Boost problem/mbc

    I CANNOT GET OVER NINE POUNDS OF BOOST EVER.i have checked the vacuum lines the bcs and the restrictor pill also i pulled off the bpv and resealed it just to make sure it wasint leaking.everything is working fine and the car is running really good just wont boost over nine pounds,so i was wondering if i could just put in a mbc and turn it up to stock boost but im new to boosted cars so i dont no.

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Master Baiter EJ257's Avatar
    Join Date
    Aug 2007
    Location
    On a stream bank somewhere
    Posts
    19,707
    I Support ClubWRX
    Can you? Probably.

    Should you? No.

    Read the following:
    Unabomber's Manifesto - NASIOC
    2005 WRX STi (Mods | Virtual Dyno)

    Resident Tuner @ WTF Tuning, LLC

    "Never trust anything that bleeds for a week and lives ..."

    UNYSOC

  4. #3
    Registered User Micah's Avatar
    Join Date
    Oct 2005
    Location
    Ocean Grove, NJ
    Posts
    4,142
    Quote Originally Posted by dubrx05 View Post
    I CANNOT GET OVER NINE POUNDS OF BOOST EVER.i have checked the vacuum lines the bcs and the restrictor pill also i pulled off the bpv and resealed it just to make sure it wasint leaking.everything is working fine and the car is running really good just wont boost over nine pounds,so i was wondering if i could just put in a mbc and turn it up to stock boost but im new to boosted cars so i dont no.
    Check the lines on the stock boost control solenoid, perhaps something isn't where it belongs. Sounds like you are running boost as controlled by the wastegate, and not by the stock boost controller.
    Torch Red 2002 Chevrolet Corvette Z06 46k mi.
    Black 2002 Subaru Impreza WRX 6-speed 94k mi. my mod list
    10/08/2006 - 14.089@103.01 (5-speed with well worn clutch, no launch)
    "Six stars gleaming, five speeds breaking, four tires chirping, three differentials working, two liters screaming, one turbo boosting... it's what makes a Subaru all-wheel-drive, all we'll drive."
    for Bugeye owners my BOV thread Service Manuals

  5. #4
    Registered User
    Join Date
    Dec 2008
    Location
    puyallup
    Posts
    19
    the lines are hooked up right we tracked down all the lines, physically checked that the pill was in by removing it out of the line and putting it back in and took a mystery pill that was in the line from the tee to the wastegate where one should not have been and checked the bcs and it is working we tightened the intercooler hoses tapped the boost gauge off the bpv and the line going into the intake manifold...cant get it right more help needed

  6. #5
    Registered User teflon_jones's Avatar
    Join Date
    Apr 2007
    Location
    8000' up in Colorado
    Posts
    6,753
    Quote Originally Posted by dubrx05 View Post
    cant get it right more help needed
    Did you read the information about MBCs that was posted above? That answers your question. You can check and recheck everything 10,000 times and you still won't find the problem.
    Scott
    Past Subies - '11 STI Limited stage 1+ and '04 STi stage 2+
    '13 Wrangler Rubicon - custom front bumper w/12k lb winch & off-road lights, skid plates, diff guards, etc.
    '04 Porsche 911 Turbo GT2 clone 600 HP/TQ
    '77 F-150 heavily modded for off-roading

  7. #6
    Registered User
    Join Date
    Dec 2008
    Location
    puyallup
    Posts
    19
    Well i dunno what their is left to do looks like the ecu has been opened up before also i have no idea what was done to this car before i bought it my only guess is that maybe the bcs is bad even though it doesnt appear to be or the ecu may be chipped or something i dunno but im extremely frusterated i need someone who actually knows what their talking about to give me some advice
    thanks

  8. #7
    Registered User teflon_jones's Avatar
    Join Date
    Apr 2007
    Location
    8000' up in Colorado
    Posts
    6,753
    Quote Originally Posted by dubrx05 View Post
    Well i dunno what their is left to do looks like the ecu has been opened up before also i have no idea what was done to this car before i bought it my only guess is that maybe the bcs is bad even though it doesnt appear to be or the ecu may be chipped or something i dunno but im extremely frusterated i need someone who actually knows what their talking about to give me some advice
    thanks
    Obviously you haven't read the information that was posted above and you just want somebody to take the time to tell you how to fix your problems, but you're not willing to do a little reading first. People will be a lot more willing to help if you read the information in the links they post and then ask follow up questions. You need some more basic information about your car and the correct way to mod it before you'll even understand the answer to your problems. So please go back and read the links people posted above, and also the stickies at the top of the forum. Then come back here and ask your questions.
    Scott
    Past Subies - '11 STI Limited stage 1+ and '04 STi stage 2+
    '13 Wrangler Rubicon - custom front bumper w/12k lb winch & off-road lights, skid plates, diff guards, etc.
    '04 Porsche 911 Turbo GT2 clone 600 HP/TQ
    '77 F-150 heavily modded for off-roading

  9. #8
    Registered User
    Join Date
    Dec 2008
    Location
    puyallup
    Posts
    19
    I read all the. Info and have done nothing but reading for three days now y don't you just tell me I no not to put a mbc on now and I think it might be the wastegate malfunctioning?
    Help me out

  10. #9
    Registered User
    Join Date
    Dec 2008
    Location
    puyallup
    Posts
    19
    o and also I don't have a computer I'm using my cell phone for this so cut me some slack

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •