getting a bad crunch sound from the suspension
Results 1 to 1 of 1

This is a discussion on getting a bad crunch sound from the suspension within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; Ok guys, so about 2 weeks ago, I installed this: Whiteline FSB Kartboy endlinks for front and rear Steering Rack ...

  1. #1
    Registered User
    Join Date
    Dec 2008
    Location
    NC
    Posts
    0

    getting a bad crunch sound from the suspension

    Ok guys, so about 2 weeks ago, I installed this:

    Whiteline FSB
    Kartboy endlinks for front and rear
    Steering Rack Bushings
    Group N tranny mount
    Tranny Crossmember bushings

    About 3 or 4 days ago, I started to notice this crunch-like sound. It happens when going over uneven surfaces. I get it both front and rear. Seems to be more noticeable the slower I am going.(5-45 mph...when it gets to about 55 or more, you cant hear it, even on uneven surfaces). I thought at first it could be a spring or strut going bad, but the car sits normal, and I havent noticed any change in the way the car behaves. I know the driveline mods can add noise, but since it didnt start this noise till nearly 2 weeks after install, I'm not so sure it's those mods.

    Any ideas?

    edit: forgot to mention, that I got under the car and checked the tightness on the FSB/RSB/endlinks, tranny mount, and crossmember bushings....everything feels tight.
    Last edited by wcu25rs; 01-04-2009 at 07:26 AM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •