lose of power, ruff idel, faint smoke
Results 1 to 11 of 11

This is a discussion on lose of power, ruff idel, faint smoke within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; List of mods include: PWR intercooler Pod filter with bonnet induction Vf 22 turbo Warbro 500hp fuel pump apexi turbo ...

  1. #1
    Registered User ozMY99wrx's Avatar
    Join Date
    Jan 2009
    Location
    AUSTRALIA
    Posts
    4

    lose of power, ruff idel, faint smoke

    List of mods include:

    PWR intercooler
    Pod filter with bonnet induction
    Vf 22 turbo
    Warbro 500hp fuel pump
    apexi turbo timer
    3 n half inch exhaust
    ECUTEK computer & custom tune
    Boost controller 2 switch 15psi & 18psi

    heres my problem....
    car has been running great the girlfriend took it for a spin the other day and blew the intercooler intake pipe off.....
    she drove the 2 mins back to a safe place to leave it...
    coughing and spluttering.....
    i rejoined everything nice and tight and the only prob i had was unused fuel comin out the exhurst ( black spots on my hand)...
    that went away after about 10 mins drivin time.....

    now 2 days later the car is running like a bag of sh$$ at low rpm .. idels at 1200rpm now ....was 900rpm - 1000rpm before....
    and today when i pulled up there was some smoke comin out of the bonnet scoop ( lasted about 30 seconds)..... there has been a faint smell of burning oil since it happened never any sign of smoke till today.......
    she seems to go ok at higher rpm and on the boost gauge reaching 15psi not a problem, just doesnt seem to be pulling as hard as it did a week ago.........

    any ideas??
    new plugs maybe??

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User twitchit's Avatar
    Join Date
    Apr 2008
    Location
    Raleigh NC
    Posts
    107
    plugs are worth a shot. I've blown my intercooler pipe off before too but i didn't have to drive far. You might also want to try resetting your ecu.

    If it's not that you might have bigger problems on your hands.

    any codes?
    05 STI....someday
    04 WRX cobb stage 2-sold
    00 Civic Si-sold
    95 240SX-sold
    02 F-350 7.3L Powerstroke Diesel

  4. #3
    Registered User ozMY99wrx's Avatar
    Join Date
    Jan 2009
    Location
    AUSTRALIA
    Posts
    4
    .... codes???
    ... this is my first performance car......
    how would i go finding / getting codes?

    forgive my ignorance.. i have just upgaded from a 1976 panelvan....

    the rex still goes pretty good up till about 160km/h... just not quite as much pull...

    and the smoke has stopped so has the smell......
    Last edited by ozMY99wrx; 01-02-2009 at 01:39 AM.

  5. #4
    Registered User twitchit's Avatar
    Join Date
    Apr 2008
    Location
    Raleigh NC
    Posts
    107
    Trouble codes...they make your check engine light come on. I'm not sure how your tuning system works though, it may have a code eliminator so you'll actually have to scan your car.

    1.) hook up obd2 code reader
    2.) read trouble codes
    3.) find out what the trouble codes mean
    4.) fix problem thats causing your car to throw the codes
    ...simple as that

    also have you checked your oil? is it low?

    oh and there is a possibility you blew off an oil line and possibly fried your turbo. I do remember about 3 days after my ic piping blew off i had an oil line come loose on the top of my turbo causing smoke to come out of the hood scoop. Possibility yes...but see if it's throwing any codes and get back to us...
    Last edited by twitchit; 01-02-2009 at 02:26 AM.
    05 STI....someday
    04 WRX cobb stage 2-sold
    00 Civic Si-sold
    95 240SX-sold
    02 F-350 7.3L Powerstroke Diesel

  6. #5
    Registered User Chalupatke's Avatar
    Join Date
    Nov 2008
    Location
    Westchester, NY
    Posts
    5

    Check the pre catalytic converter

    I didnt see an uppipe in your list of mods. If thats the case, the pre cat might of went. The pre cat is the first of three catalyitic converters in the wrx. Its right before the turbo and if it overheats it can melt and cause decreased air flow to the turbo causing less power and a rough idle. This just happened to mine. The rough and low idle even went to the point of stalling for me. I experienced loss of power too. The CEL eventually came on due to the rise in temp. The stock turbo eventually completely failed because when the precat melted and fell apart, it sent small pieces into the turbo! The one good thing that came out of this whole ordeal is an upgraded Big 16G turbo that i got in replace of the stock TD04 and an uppipe to replace the precat. If you do still have a precat, it might be worth checking out a catless uppipe. It adds some power and protects the turbo too. Good luck!

  7. #6
    Registered User ozMY99wrx's Avatar
    Join Date
    Jan 2009
    Location
    AUSTRALIA
    Posts
    4

    well after a bit of troubleshooting i have just pulled out my plugs..... check no.2 plug!!!




    what do ya reckon.... ring gone or what?
    Attached Thumbnails Attached Thumbnails New 195.jpg   intercoolerexit.jpg  
    Last edited by ozMY99wrx; 01-03-2009 at 07:56 PM.

  8. #7
    Registered User twitchit's Avatar
    Join Date
    Apr 2008
    Location
    Raleigh NC
    Posts
    107
    Well i hate to say it but it does look like a fried ring just from the blowby in the ic piping.

    but you might as well throw in a new set of plugs...she might have just fouled the cylinder 2 plug(best case scenario)...so put the new plugs in and see what happens. If it works then you just saved yourself a rebuild. If it doesn't then build it better and stronger than before. Try the cheapest solution first and then go from there.
    05 STI....someday
    04 WRX cobb stage 2-sold
    00 Civic Si-sold
    95 240SX-sold
    02 F-350 7.3L Powerstroke Diesel

  9. #8
    Registered User teflon_jones's Avatar
    Join Date
    Apr 2007
    Location
    8000' up in Colorado
    Posts
    6,753
    So you went from a '76 panel van to a highly modified Subaru?

    Did you modify the car yourself, or did you buy it already modified?
    Scott
    Past Subies - '11 STI Limited stage 1+ and '04 STi stage 2+
    '13 Wrangler Rubicon - custom front bumper w/12k lb winch & off-road lights, skid plates, diff guards, etc.
    '04 Porsche 911 Turbo GT2 clone 600 HP/TQ
    '77 F-150 heavily modded for off-roading

  10. #9
    Registered User ozMY99wrx's Avatar
    Join Date
    Jan 2009
    Location
    AUSTRALIA
    Posts
    4
    not a chance did i mod her myself...... but after a couple more break downs ill prob be able to build my next 1... hahahaha

    for how much stuff is under the hood its a nice motor to work on.....

  11. #10
    Moderator Donkey's Avatar
    Join Date
    Apr 2005
    Location
    Da boonies
    Posts
    5,970
    I Support ClubWRX
    Get a compression/leak down test done on the cylinders.This will pinpoint the condition of the motor.
    Resident Adviser @ WTF Tuning, LLC
    2002 FORESTER S
    1998 FORESTER S




  12. #11
    Registered User twitchit's Avatar
    Join Date
    Apr 2008
    Location
    Raleigh NC
    Posts
    107
    Quote Originally Posted by donkey View Post
    get a compression/leak down test done on the cylinders.this will pinpoint the condition of the motor.
    +1
    05 STI....someday
    04 WRX cobb stage 2-sold
    00 Civic Si-sold
    95 240SX-sold
    02 F-350 7.3L Powerstroke Diesel

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •