sputtering/flickering sound need help
Results 1 to 4 of 4

This is a discussion on sputtering/flickering sound need help within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; Hey everybody I have a 2004 subaru wrx well it seems there's a sputtering/flickering sound coming from the what sounds ...

  1. #1
    Registered User
    Join Date
    Sep 2007
    Posts
    2

    sputtering/flickering sound need help

    Hey everybody I have a 2004 subaru wrx well it seems there's a sputtering/flickering sound coming from the what sounds like driverside front and only seem to hear it during acceleration. my idle is at 500rpm if that is right. I was thinking fuel injector but not sure seems like it's robbing some power from the car just recently repaired fuel pump to clear cel and felt like some power came back but it seems to be really effecting my lower rpms. help is appreciated. and i can smell from the driver front side under the hood burning coolant smell and smoke sometimes and usually when it's cold. all of which though makes that low rpm feel real shaky and powerless.

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User EvoEatr's Avatar
    Join Date
    Aug 2008
    Location
    Kennett Square, Pennsylvania
    Posts
    1,839
    when was the last time you replaced the fuel filter? spark plugs?....When this happens the CEL doesnt come on? just from the way you describe it it sounds like a misfire but that should obviously throw a code at the first sign of a miss....does the vehicle run ok otherwise...cruise? idle?

  4. #3
    Registered User 2:43AM's Avatar
    Join Date
    Sep 2008
    Location
    NWI
    Posts
    647
    Quote Originally Posted by jokerstyle85 View Post
    Hey everybody I have a 2004 subaru wrx well it seems there's a sputtering/flickering sound coming from the what sounds like driverside front and only seem to hear it during acceleration. my idle is at 500rpm if that is right. I was thinking fuel injector but not sure seems like it's robbing some power from the car just recently repaired fuel pump to clear cel and felt like some power came back but it seems to be really effecting my lower rpms. help is appreciated. and i can smell from the driver front side under the hood burning coolant smell and smoke sometimes and usually when it's cold. all of which though makes that low rpm feel real shaky and powerless.
    Man, you're all over the place with assumptions! Check one thing at a time. Check all fluids first and foremost. Also, there are known radiator and hose leaks with the 04-05 models. Mine was right above the turbo. A new hose clamp cleared it right up!

    Is the new fuel pump a correct one? Remember, these cars have turbo lag. You won't get gobs of torque until you get a little boost going. Us 2.0L drivers suffer a bit from the lack of torque compared to the 2.5L drivers out there. We just have to deal and be creative!

  5. #4
    Registered User
    Join Date
    Sep 2007
    Posts
    2
    i have not replaced the fuel filter that could be where i will start first than replace the plugs, the last time i replaced the plugs was about september of 07 so i'm sure i'm behind just wanted to know a good route to go with before i just started replacing everything. i just know the car is capable of better performance or at least want to get it running back to stock levels. but i really appreciate the advice guys. i'll look into that fuel pump too make sure it's the right one. and check on my fluids and such. it's just the car seems to have a low idle but yeah it seems after the car starts getting some boost going it'll move just that sputtering flickering sound is what bugs me. other than that starts fine doesn't overheat not completly gutless, but i was just wondering if it would be better to just start with the fuel filter and plugs or go right for the fuel injectors.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •