turbo question
Results 1 to 2 of 2

This is a discussion on turbo question within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; i have an 04 wrx. i'm running cobb access port stage 2 with turboxs turbo back catless race pipe just ...

  1. #1
    Registered User conorpeterson85's Avatar
    Join Date
    Oct 2007
    Location
    sacramento
    Posts
    15

    turbo question

    i have an 04 wrx. i'm running cobb access port stage 2 with turboxs turbo back catless race pipe just passed 80,000 miles. Just in the last couple of days when the turbo start to pull it sounds like it's not getting enough air, a weird sucking noise is the best way i can describe it. also just today the turbo started to "chirp". when. when i was warming the car up it would "chirp" sounding like a atmospheric BOV. MY BOV the stock is recirculating one. any ideas on what this could be?

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User atrizzzie's Avatar
    Join Date
    Sep 2008
    Location
    Seekonk, Massachusetts
    Posts
    282
    is the oil level full? it could be getting a lack of oil at startup possibly. did you check all hoses going to the turbo and bof. sounds like the turbo may be nearing the end of its life to me tho

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •