help me please
Results 1 to 4 of 4

This is a discussion on help me please within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; ok well here is my problem i just bought this impreza WRx and it was running fine i was cruising ...

  1. #1
    Registered User jessie_james_06's Avatar
    Join Date
    Dec 2008
    Location
    houston texas
    Posts
    13

    help me please

    ok well here is my problem i just bought this impreza WRx and it was running fine i was cruising down the innerstate and it started spitting and acting up i dont know what the problem could be i have hooked it up to a scanner and it reads these codes 1- high exhaust temp 2-o2 sensor lean in bank 1 and 3- manufacturer speed sensor and idle control so if anyone has any ideas as to what could be the problem hit me up

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User jessie_james_06's Avatar
    Join Date
    Dec 2008
    Location
    houston texas
    Posts
    13
    Quote Originally Posted by jessie_james_06 View Post
    ok well here is my problem i just bought this impreza WRx and it was running fine i was cruising down the innerstate and it started spitting and acting up i dont know what the problem could be i have hooked it up to a scanner and it reads these codes 1- high exhaust temp 2-o2 sensor lean in bank 1 and 3- manufacturer speed sensor and idle control so if anyone has any ideas as to what could be the problem hit me up

  4. #3
    Registered User Truckster27's Avatar
    Join Date
    Mar 2006
    Location
    Everywhere
    Posts
    560
    Well, I see you're new....lets get a little more information before we make blind diagnoses:
    1.)Define "acting up". Bucking, losing power, losing boost, etc.
    2.)Define "spitting". Fluid discharge, backfire, etc.
    3.) Year, and model (wrx, sti, etc.)
    4.) What mods do you have (I'm thinking a BOV...what else?)

    This will some to make an educated guess....
    Movn' on up to an '06 WRX
    Vf-39 all the way!

    Love to build 'em, just to ship 'em out and start all over!

    I got friends in cyberspace, so I must be cool, right?
    Facebook / Myspace

  5. #4
    Registered User laruffa's Avatar
    Join Date
    Jun 2008
    Location
    Los Angeles
    Posts
    113
    do yourself a favor...

    take that BOV off and put on the stock BPV

    take of the AEM CAI and put the stock intake back on

    if you don't have those parts, buy them

    if you have dp and uppipe with your 3 inch exhaust....get a tune
    San Remo Alliance............#001


    "The imagination of nature is far, far greater than the imagination of man." Richard Feynman

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •