Need help diagnosing....
Results 1 to 2 of 2

This is a discussion on Need help diagnosing.... within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; Hey guys, For the past two weeks I have been experiencing some issues w/ my 03 WRX (82,000 m) and ...

  1. #1
    Registered User
    Join Date
    Dec 2008
    Posts
    5

    Need help diagnosing....

    Hey guys,

    For the past two weeks I have been experiencing some issues w/ my 03 WRX (82,000 m) and was hoping you guys could give a diagnosis. I will describe the issues to the best of my limited knowledge.

    My car is having issues in 4th and 5th as I move through the power band between 3,000 and 4,000 rpms. Whenever I WOT at about 3,100 it disengages and shoots up to 4000 flutters for a brief second(like hitting a rev limiter). It then drop back to spooling level and sluggishly moves to a higher rpm. I have no problem driving my car at low rpms in lower gears. It usually moves through the rpms fine when I go through 1st,2nd, and 3rd.

    I am not sure if this has to do with clutch, tranny, drive shaft, etc. Any help in diagnosing it and with rough estimates would be great. Let me know if you need any more info.

    Thanks!

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User EvoEatr's Avatar
    Join Date
    Aug 2008
    Location
    Kennett Square, Pennsylvania
    Posts
    1,839
    sounds to me like your clutch is slipping.....do you notice this alot when you give it WOT or when going up hills?....the next time your out and you feel like giving it some gas in 2nd or 3rd if the RPMS shoot up and than come back down id say its time to start saving for a new clutch.....

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •