Help me please!
+ Reply to Thread
Results 1 to 9 of 9

This is a discussion on Help me please! within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; just went WOT in third gear and got code P0244 "wastegaste solenoid "A"" What do i do? can i still ...

  1. #1
    Registered User Findus11's Avatar
    Join Date
    Nov 2007
    Location
    Ketchum, Idaho
    Posts
    670

    Help me please!

    just went WOT in third gear and got code P0244

    "wastegaste solenoid "A""

    What do i do?
    can i still drive?
    Hawk Eye #1991
    Dirty Crew #11
    Military Militia #1991
    I still don't know how I got this car...

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User Findus11's Avatar
    Join Date
    Nov 2007
    Location
    Ketchum, Idaho
    Posts
    670
    anyone please?
    i put the car in econ mode and drove under no load the rest of the way home. Should i replace the solenoid?
    Hawk Eye #1991
    Dirty Crew #11
    Military Militia #1991
    I still don't know how I got this car...

  4. #3
    Registered User STI_KLR's Avatar
    Join Date
    Dec 2007
    Location
    The taint of Northern Virginia.
    Posts
    3,740
    do you have a MBC? Has the weather gotten drastically colder the past few days?
    Rogan: Live simply, love generously, care deeply, speak kindly.
    Mods List Build Thread
    Bugeye Mafia #196 High Mileage Club
    Fully Built EJ257 HYBRID & JDM STI 6-Speed

    Miniature Awesomness

  5. #4
    Registered User Findus11's Avatar
    Join Date
    Nov 2007
    Location
    Ketchum, Idaho
    Posts
    670
    no mbc
    temp is in the 30-40's at times though...
    Hawk Eye #1991
    Dirty Crew #11
    Military Militia #1991
    I still don't know how I got this car...

  6. #5
    Registered User STI_KLR's Avatar
    Join Date
    Dec 2007
    Location
    The taint of Northern Virginia.
    Posts
    3,740
    Quote Originally Posted by Findus11 View Post
    no mbc
    temp is in the 30-40's at times though...
    If the temp. outside drops drastically, it can cause the car to run a little higher boost. Same thing happened to me when the weather plummeted from high 70's to 24 degrees at 1am. I turned the boost down to compensate and everything has been good since.

    I would clear the code, and see if it comes back again.

    If it does, I would try possibly tightening the wastegate arm a turn or two and see if the code comes back.


    Other than that, I'm out of ideas
    Rogan: Live simply, love generously, care deeply, speak kindly.
    Mods List Build Thread
    Bugeye Mafia #196 High Mileage Club
    Fully Built EJ257 HYBRID & JDM STI 6-Speed

    Miniature Awesomness

  7. #6
    Registered User Findus11's Avatar
    Join Date
    Nov 2007
    Location
    Ketchum, Idaho
    Posts
    670
    ok thanks a lot
    would you recommend replacing the solenoid?
    it seems like it has been acting weird for a while...
    Hawk Eye #1991
    Dirty Crew #11
    Military Militia #1991
    I still don't know how I got this car...

  8. #7
    Registered User ajd111's Avatar
    Join Date
    Jun 2007
    Location
    Pittsburgh, PA
    Posts
    897
    You shouldn't have to adjust the wastegate arm, that was a trick for older wrx's but I believe on the new ones you shouldn't have to worry about it. As for the weather thing, I can see that being the problem. I had the same thing happen to me on a road trip once. I cleared it and it never came back.
    Quote Originally Posted by BrianH View Post
    Careful, I still think she's packin wang.

  9. #8
    Master Baiter EJ257's Avatar
    Join Date
    Aug 2007
    Location
    On a stream bank somewhere
    Posts
    19,853
    I Support ClubWRX
    The code is not a big deal - I've thrown it twice this fall, and reset the ECU both times, and it went away.
    2005 WRX STi (Mods | Virtual Dyno)

    Resident Tuner @ WTF Tuning

    "Never trust anything that bleeds for a week and lives ..."

    UNYSOC

  10. #9
    Registered User Findus11's Avatar
    Join Date
    Nov 2007
    Location
    Ketchum, Idaho
    Posts
    670
    alright thanks guys!
    Hawk Eye #1991
    Dirty Crew #11
    Military Militia #1991
    I still don't know how I got this car...

+ Reply to Thread

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself. We strongly suggest that you stay away from using aol, yahoo, msn, and hotmail accounts. Sometimes the mail server blocks the emails from our server. As a result you will not receive any notifications including the confirmation email.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •