Oxygen Sensor Help!!
Results 1 to 2 of 2

This is a discussion on Oxygen Sensor Help!! within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; I just installed an up pipe on my car and my o2 sensor went out (the up-stream one right before ...

  1. #1
    Registered User
    Join Date
    Nov 2006
    Posts
    28

    Oxygen Sensor Help!!

    I just installed an up pipe on my car and my o2 sensor went out (the up-stream one right before the up pipe) i bought a bosch universal sensor and when i wired it up the check engine light cut right back on and gave me the same code, I read that the bosch o2 sensors for our cars are trash, and i should either purchase a denso or an oem one? if i'm able to use the denso sensor would a universal one work? I read that the issue with universal sensors is the connection or where they connect with factory harness. So i'm guessing a denso universal wouldn’t work? or would it? My buddy has a wrx too and his same sensor went out and he replaced it with a universal one that a muffler shop sold him. I'm really confused and really frustrated Please help.

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User EvoEatr's Avatar
    Join Date
    Aug 2008
    Location
    Kennett Square, Pennsylvania
    Posts
    1,839
    Buy OEM....subarus are very touchy with certain aftermarket components... 02 sensors being one of them....

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •