My car Threw a CEL Need some Help!!
Results 1 to 9 of 9

This is a discussion on My car Threw a CEL Need some Help!! within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; OK so last night i was coming home from work and driving on the usual road. it was raining outside ...

  1. #1
    Registered User pyroxx950's Avatar
    Join Date
    Oct 2008
    Location
    Forked River
    Posts
    39

    My car Threw a CEL Need some Help!!

    OK so last night i was coming home from work and driving on the usual road. it was raining outside and i went to make my standard right turn. came to the stop sign stopped and went on my way and i noticed that a cel light came on out of know where. i have no idea what it could be from. any advice?
    how can i check what code it is if i dont own a scanner?

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Sammich Makin' Pwincess wrxtreme06's Avatar
    Join Date
    May 2007
    Location
    orlando flawduh
    Posts
    12,505
    I Support ClubWRX
    we would need the code before we can help you


    go to autozone or mostly any autoparts store and they can scan it for you

    desiree
    your friendly, neighborhood subaru girl
    abbigale : 06 impreza wrx tr: cobb stage II
    hawkeye alliance #11:11//
    wingl3ss @ll!ance #17 // lvl 80 N.E.R.D.

  4. #3
    Registered User teflon_jones's Avatar
    Join Date
    Apr 2007
    Location
    8000' up in Colorado
    Posts
    6,752
    Quote Originally Posted by wrxtreme06 View Post
    we would need the code before we can help you
    +1

    You also don't list the year/model of your car, any mods, or any changes you've done recently.
    Scott
    Past Subies - '11 STI Limited stage 1+ and '04 STi stage 2+
    '13 Wrangler Rubicon - custom front bumper w/12k lb winch & off-road lights, skid plates, diff guards, etc.
    '04 Porsche 911 Turbo GT2 clone 600 HP/TQ
    '77 F-150 heavily modded for off-roading

  5. #4
    Admiral Ackbar mycologist's Avatar
    Join Date
    Oct 2005
    Location
    Late Devonian
    Posts
    12,423
    I Support ClubWRX
    I'm going out on a limb and guessing that your gas cap is loose or needs to be replaced. Just a hunch until you post the code though.
    "From a little spark may burst a mighty flame." - Dante
    "The stitch is lost unless the thread is knotted." - Italian proverb

  6. #5
    Registered User pyroxx950's Avatar
    Join Date
    Oct 2008
    Location
    Forked River
    Posts
    39

    the code

    ok i went to autozone and the guy scanned the car.

    i forget the actual code but it was the code for the knock sensor. the code was like p307 or summin like that.

    after i got done with auto zone a little later the cel was gone. but now my car runs like ****. its as if its not boosting. or boosting really slow now.

    i try to get on it to see if it will boost and it went to 7k rpm and i was only at aboput 30mph in first. im not sure if it was due to the wet roads, meaning the car wasnt grabbing or what.


    05 subaru wrx. stock no mods

  7. #6
    Registered User NjBuGeyEdWRX's Avatar
    Join Date
    Apr 2007
    Location
    Beachwood NJ
    Posts
    1,340
    Quote Originally Posted by pyroxx950 View Post
    i try to get on it to see if it will boost and it went to 7k rpm and i was only at aboput 30mph in first. im not sure if it was due to the wet roads, meaning the car wasnt grabbing or what.


    05 subaru wrx. stock no mods

    well i think you can tell if your car got lose or not the back ends slides out just alittle bit. but if it is grabbing and you reved out and werent really moving then your clutch is slipping.
    03 WRB WRX STAGE II
    STi COMING SOON

    BUGEYE MAFIA #199

    LET ME QUOTE THE LATE COLONEL SANDERS " I'M TO DRUNK TO TASTE THIS CHICKEN . . ."

  8. #7
    Registered User pyroxx950's Avatar
    Join Date
    Oct 2008
    Location
    Forked River
    Posts
    39

    another issue

    ok so the clutch could be the problem. im new to stick cars so i cant tell if its slipping or not. tomarrow my freind is going to drive the car and let me know if it is the cluctch but now i have some more news.

    i was driving home from college like an hour ago and all of a sudden i got this really bad smell coming into my cabin.
    the smell smelt like burnt, like sothing burnt. so when i stop a little later i pop'd open my hood and smelled to see if i could tell where it was coming from. and love and behold the burnt smell seemed to be coming from the turbo.

    i also noticed when i was driving on the parkway going around 60mph with my radio on the turbo was making a louder noise than usual. so i turn my radio off and the turbo was not making its normal noise it was louder.( i noticed this b4 i popped my hood)

    so now in thinking my turbo just went bad. what do you guys make from all this

  9. #8
    Admiral Ackbar mycologist's Avatar
    Join Date
    Oct 2005
    Location
    Late Devonian
    Posts
    12,423
    I Support ClubWRX
    Too bad it wasn't the gas cap, that would have been a little easier. It does sound like your turbo is bad - at least the oil seals are probably shot and this may explain the knock code as well.

    There was a TSB about a screen in the oil feed that can get clogged - be sure you take care of that before you put in a new turbo.

    30 sounds about right for redline in first but check your owners manual they have it in there.
    "From a little spark may burst a mighty flame." - Dante
    "The stitch is lost unless the thread is knotted." - Italian proverb

  10. #9
    Registered User pyroxx950's Avatar
    Join Date
    Oct 2008
    Location
    Forked River
    Posts
    39
    i had my dad take a look at my car he drove it for a little and said the clutch seemed fine and them he smelt the burnt smell i told him about and he said it was my clutch. and that if the clutch was going thats why my car rev'd higher than it was moving. so i think i might need a clutch too.

    how much does the oem clutch go for?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •