Intermintent boost fluctuation
+ Reply to Thread
Results 1 to 6 of 6

This is a discussion on Intermintent boost fluctuation within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; Having problem with boost fluctuation. Boost bounces between .12 and .06, but not all the time. Sometimes I can let ...

  1. #1
    Registered User
    Join Date
    Feb 2008
    Location
    So. Jersey
    Posts
    21

    Intermintent boost fluctuation

    Having problem with boost fluctuation. Boost bounces between .12 and .06, but not all the time. Sometimes I can let it build slowly(roll on throttle) and it will hold at .1 until I shift. Sometimes it won't and starts to bounce. I cleaned the boost controller, and can hear it working(faint click when 12 volts applied). Cleaning changed nothing. The car used to boost fine till about 2 months ago, and had been getting slightly worse.

    Car is a stock 2003 except for XS intercooler hoses, Prodrive axle back, and K&N drop in. I don't hear any boost leaks when its on boost. Seems like the boost controller can't cope with boost building too fast, over shoots, then can't catch up. Was going to replace the boost controller, but wanted to run it by you guys for any other ideas first. Would adjusting the waste gate arm fix this? Sorry for the long post, but any help is appreciated.
    Last edited by boll58; 10-29-2008 at 06:53 AM.

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User NjBuGeyEdWRX's Avatar
    Join Date
    Apr 2007
    Location
    Beachwood NJ
    Posts
    1,340
    what mbc do you have?
    03 WRB WRX STAGE II
    STi COMING SOON

    BUGEYE MAFIA #199

    LET ME QUOTE THE LATE COLONEL SANDERS " I'M TO DRUNK TO TASTE THIS CHICKEN . . ."

  4. #3
    Admiral Ackbar the 1st mycologist's Avatar
    Join Date
    Oct 2005
    Location
    Late Devonian
    Posts
    13,319
    I Support ClubWRX
    Quote Originally Posted by boll58 View Post
    Having problem with boost fluctuation. Boost bounces between .12 and .06, but not all the time. Sometimes I can let it build slowly(roll on throttle) and it will hold at .1 until I shift. Sometimes it won't and starts to bounce. I cleaned the boost controller, and can hear it working(faint click when 12 volts applied). Cleaning changed nothing. The car used to boost fine till about 2 months ago, and had been getting slightly worse.

    Car is a stock 2003 except for XS intercooler hoses, Prodrive axle back, and K&N drop in. I don't hear any boost leaks when its on boost. Seems like the boost controller can't cope with boost building too fast, over shoots, then can't catch up. Was going to replace the boost controller, but wanted to run it by you guys for any other ideas first. Would adjusting the waste gate arm fix this? Sorry for the long post, but any help is appreciated.
    I would suspect the boost control solenoid. If you can find someone to swap theirs in for a minute you can tell that way.

    It is not going to be fixed with an arm adjustment.


    Quote Originally Posted by NjBuGeyEdWRX View Post
    what mbc do you have?
    None I assume.
    "From a little spark may burst a mighty flame." - Dante
    "The stitch is lost unless the thread is knotted." - Italian proverb

  5. #4
    Registered User
    Join Date
    Feb 2008
    Location
    So. Jersey
    Posts
    21
    Well I swapped the FBC today, and no change. Also replaced all the vacumn lines involved in the boost controller. I am at lost now. Could the waste gate acuator be bad? I unhooked the waste gate arm and the waste gate moves freely.

  6. #5
    Admiral Ackbar the 1st mycologist's Avatar
    Join Date
    Oct 2005
    Location
    Late Devonian
    Posts
    13,319
    I Support ClubWRX
    Quote Originally Posted by boll58 View Post
    Well I swapped the FBC today, and no change. Also replaced all the vacumn lines involved in the boost controller. I am at lost now. Could the waste gate acuator be bad? I unhooked the waste gate arm and the waste gate moves freely.
    Is the pill in there?
    "From a little spark may burst a mighty flame." - Dante
    "The stitch is lost unless the thread is knotted." - Italian proverb

  7. #6
    Registered User
    Join Date
    Feb 2008
    Location
    So. Jersey
    Posts
    21
    Yeah the pill in still in the hose from the turbo outlet to T. I didn't change that hose because is was still flexible. I took a lot of preload off the waste gate arm, and that didn't change a thing either. Tomorrow I'll try adding more preload to see if it changes anything. I'm also reseting the ECU after each change I'm making.

+ Reply to Thread

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself. We strongly suggest that you stay away from using aol, yahoo, msn, and hotmail accounts. Sometimes the mail server blocks the emails from our server. As a result you will not receive any notifications including the confirmation email.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •