Engine mount advice on a 1994 WRX!!!
+ Reply to Thread
Results 1 to 6 of 6

This is a discussion on Engine mount advice on a 1994 WRX!!! within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; Hi all, I have noticed that my engine wobbles more recently on start up as alot once it is turned ...

  1. #1
    Registered User
    Join Date
    Jan 2008
    Posts
    41

    Red face Engine mount advice on a 1994 WRX!!!

    Hi all,
    I have noticed that my engine wobbles more recently on start up as alot once it is turned off, the wobble can be felt inside the car aswel.
    While driving if im cruising along in 1st gear and do a gear change to 2nd once i bring the clutch back up i get a knock as if the engine or part of it is kncking against something.
    Am i right in thinking this is a worn engine/transmission mounts??
    also how costly would this sort of problem be??

    any help appreciated!!
    Thanks in advance peepl!!
    Last edited by az_e11; 10-26-2008 at 01:08 PM.

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User
    Join Date
    Jan 2008
    Posts
    41
    Any one got any ideas??
    or has no one ever had such a problem??
    Last edited by az_e11; 10-26-2008 at 01:13 PM.

  4. #3
    Registered User
    Join Date
    Jan 2008
    Posts
    41
    I dont know why, but i get the feeling its more the tranny mount rather than the engine, as when i feel the knockin movement the gear lever moves up and down.
    any 1 had this sort of problem???

  5. #4
    Registered User atrizzzie's Avatar
    Join Date
    Sep 2008
    Location
    Seekonk, Massachusetts
    Posts
    282
    you probably need some motor mounts and a trans mount. pop the hood n rev the engine and see if thats the case. it will probably cost a couple hundred for parts

  6. #5
    Registered User
    Join Date
    Jan 2008
    Posts
    41
    oh right i see, would you recommend the standard part or should i get a more expensive part??

  7. #6
    The Default One SeattleJeremy's Avatar
    Join Date
    Jul 2004
    Location
    Seattle, WA
    Posts
    4,488
    The standard part is the one installed in the car now. It lasted 14 years. So I'd say go for that one again.

+ Reply to Thread

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself. We strongly suggest that you stay away from using aol, yahoo, msn, and hotmail accounts. Sometimes the mail server blocks the emails from our server. As a result you will not receive any notifications including the confirmation email.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •