Help!!!
+ Reply to Thread
Results 1 to 7 of 7

This is a discussion on Help!!! within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; ok so im driving down the road and all a sudden my turbo quit working wont spool up at all ...

  1. #1
    Registered User
    Join Date
    Oct 2008
    Posts
    2

    Exclamation Help!!!

    ok so im driving down the road and all a sudden my turbo quit working wont spool up at all car is extremely sluggish! it lasted for about a mile then it started working again i drove it all day and it ran like a beast then later on that nite it happend again! so i pull over and turn it off then try to start it and it starts but it shuts off on its own after like two seconds??? HELP PLEASE

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User NjBuGeyEdWRX's Avatar
    Join Date
    Apr 2007
    Location
    Beachwood NJ
    Posts
    1,340
    idk what to say about the turbo never heard anything like that. but if the car starts and shuts off check the fuel filter maybe its clogged
    03 WRB WRX STAGE II
    STi COMING SOON

    BUGEYE MAFIA #199

    LET ME QUOTE THE LATE COLONEL SANDERS " I'M TO DRUNK TO TASTE THIS CHICKEN . . ."

  4. #3
    Registered User indytruckboy's Avatar
    Join Date
    Oct 2008
    Location
    Reading, PA
    Posts
    492
    Could be a lot of things. CEL come on at all?

  5. #4
    Registered User
    Join Date
    Oct 2008
    Posts
    2
    what do yyou mean by CEL?

  6. #5
    Registered User DubleUaReX's Avatar
    Join Date
    Oct 2005
    Location
    Galena, Ohio
    Posts
    130
    Quote Originally Posted by tyla05wrx View Post
    what do yyou mean by CEL?
    Oh lord.....this should be fun!

    Check
    Engine
    Light

  7. #6
    Registered User
    Join Date
    Oct 2008
    Location
    nj
    Posts
    126
    have you done any work on your car recently?

  8. #7
    The Default One SeattleJeremy's Avatar
    Join Date
    Jul 2004
    Location
    Seattle, WA
    Posts
    4,488
    Quote Originally Posted by jaytech View Post
    have you done any work on your car recently?
    +1, any Exhaust or intake work?

    What are your mods? How long have you had the car?

+ Reply to Thread

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself. We strongly suggest that you stay away from using aol, yahoo, msn, and hotmail accounts. Sometimes the mail server blocks the emails from our server. As a result you will not receive any notifications including the confirmation email.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •