Brake and Battery Light ON? Why
Results 1 to 8 of 8

This is a discussion on Brake and Battery Light ON? Why within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; Can anyone tell me why my battery and brake lites come on and the driving lights go out? The alternator ...

  1. #1
    Registered User
    Join Date
    Jul 2008
    Location
    south cental PA
    Posts
    14

    Unhappy Brake and Battery Light ON? Why

    Can anyone tell me why my battery and brake lites come on and the driving lights go out? The alternator is fine, the brake fluid is fine. I know of a diode between the two circuts. Could this have failed closed? If so, why do the driving lights go out. BTW, the lights on condition is intermitt:

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    DUB
    DUB is offline
    Registered User DUB's Avatar
    Join Date
    Jul 2007
    Location
    SLT, CA
    Posts
    3,176
    Have your battery tested, it's probably done for.

  4. #3
    Registered User
    Join Date
    Jul 2008
    Location
    south cental PA
    Posts
    14
    Battery is fine

  5. #4
    He simply abides. SD_GR's Avatar
    Join Date
    Jul 2002
    Location
    CA, US
    Posts
    22,291
    I Support ClubWRX
    My bet initially was the alternator. If not, a connection to the alternator. If not that -- you say you've tested it -- then something like this:
    Help me diagnose no charge problem - not alternator!???? - 3000GT/Stealth International Message Center
    I suppose the diode you mention could be an issue. Is there a >100A fuse or fusible link in the Subaru?
    WRX Info Links, Courtesy TheJ
    The world breaks everyone and afterward many are strong in the broken places. Ernest Hemingway
    I lied. I cheated. I bribed men to cover the crimes of other men. I am an accessory to murder. But the most damning thing of all... I think I can live with it. And if I had to do it all over again - I would. Benjamin Sisko
    DISCLAIMER: Opinions expressed are the author's alone and are inherently worthless.

  6. #5
    Registered User
    Join Date
    Jul 2008
    Location
    south cental PA
    Posts
    14
    Thanks SD_GR for the link. Its not the fuse since the car runs when the battery is disconnected. The alternater is working properly.

  7. #6
    Registered User
    Join Date
    Oct 2009
    Posts
    4
    Quote Originally Posted by dblrz1 View Post
    Can anyone tell me why my battery and brake lites come on and the driving lights go out? The alternator is fine, the brake fluid is fine. I know of a diode between the two circuts. Could this have failed closed? If so, why do the driving lights go out. BTW, the lights on condition is intermitt:
    I just bought a 2002 wrx and had it break down less than 24 hours after purchase? I bought a new optima red battery, and still couldn't start the car! Had the alternator tested and it was bad. replaced the alternator and still have a battery light and emergency brake light coming on? I have pulled off the road, charged the battery and the light goes away? started driving agian and after a few miles both light turn on again? I have only had the car two days and already don't like it!!!!
    Now I see that other people have the same problem, but what is the solution?????????????????????????????????????????? ?

  8. #7
    Registered User
    Join Date
    Oct 2009
    Posts
    4
    Quote Originally Posted by carl_32 View Post
    I just bought a 2002 wrx and had it break down less than 24 hours after purchase? I bought a new optima red battery, and still couldn't start the car! Had the alternator tested and it was bad. replaced the alternator and still have a battery light and emergency brake light coming on? I have pulled off the road, charged the battery and the light goes away? started driving agian and after a few miles both light turn on again? I have only had the car two days and already don't like it!!!!
    Now I see that other people have the same problem, but what is the solution?????????????????????????????????????????? ?
    To be more specific! The battery is brand new and the alternator is brand new and I STILL get both warning lights while driving!!! and like the other guy, my headlights shut off while driving! WTF that is BS!!

  9. #8
    Registered User EvoEatr's Avatar
    Join Date
    Aug 2008
    Location
    Kennett Square, Pennsylvania
    Posts
    1,839
    I'm assuming you guys have checked the drive belt for the alt/ps pump? Did you end up purchasing a Subaru OEM alternator? There was a recall on some earlier model legacies about a diode failing in the alternator, the result of this is usually feedback from certain circuits in the car : example: Power windows will continue to try to operate even without the switch depressed....However I have yet to hear anything about the WRX's... My recommedation to both of you although your battery is new and alt. is new is to load test the battery and do an alt. output test...just to like 100% rule them both out..fore Ive seen remanned alt. malfunction out of the box...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •