Turn signals went out
+ Reply to Thread
Results 1 to 3 of 3

This is a discussion on Turn signals went out within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; Well so i was driving home yesterday and i put my left turn signal on and nothing happened. Put my ...

  1. #1
    Registered User
    Join Date
    May 2008
    Posts
    1

    Turn signals went out

    Well so i was driving home yesterday and i put my left turn signal on and nothing happened. Put my right signal on and nothing happened and the same when i put my hazard lights on. I checked the fuses under the hood and the one labeled turn signals was good. I replaced it anyway. I couldnt find the other fuse box but i just read on these forums its behind the coin tray. Ill check that on my lunch break but has anyone else had this problem and if so, what did it take to fix it? Is it a fuse issue or am i looking at a more expensive repair?

    *ok so i just checked the other fuses and they are all ok. Ayone have any ideas on what it could be?
    Last edited by whatever113; 08-26-2008 at 01:59 PM.

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User DForez's Avatar
    Join Date
    May 2009
    Posts
    71
    I just encountered the exact same problem as above.. any one have any ideas

  4. #3
    Registered User DForez's Avatar
    Join Date
    May 2009
    Posts
    71
    forget it, I was installing my boost gauge and had my hazard lights button unplugged. now it works. Im dumb..

+ Reply to Thread

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself. We strongly suggest that you stay away from using aol, yahoo, msn, and hotmail accounts. Sometimes the mail server blocks the emails from our server. As a result you will not receive any notifications including the confirmation email.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •