o2 senson
+ Reply to Thread
Results 1 to 5 of 5

This is a discussion on o2 senson within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; engine light came on, went to autozone and they told me it was the o2 sensor. i drive on 05 ...

  1. #1
    Registered User
    Join Date
    Jun 2008
    Location
    Oregon
    Posts
    29

    o2 senson

    engine light came on, went to autozone and they told me it was the o2 sensor. i drive on 05 wrx and was wondering if i should bring it in or just fix it myself? i've never done it before but i can't imagine it's that difficult... any suggestions?

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User JUSTINSNUTSWINGER's Avatar
    Join Date
    Jul 2008
    Location
    San Antonio
    Posts
    1,923
    Get some crap to loosen it up a little a few hours before you get underneath to see if it will / can break loose. 15 minute job at the most to do it yourself....

  4. #3
    Registered User PRIMAJIN's Avatar
    Join Date
    Jul 2008
    Location
    Doylestown
    Posts
    47

    o2sensor

    I drive an 04 sti, i believe i have the same problem, code read was. P0171 system is too lean Bank 1. im understanding that i have to replace an 02 sensor, however im not sure witch one. Does anyone know how to find the o2 sensor that is bad, with the information that i gave ya. thanx fellas

  5. #4
    Is in Love With the Admins Here 20WRX04's Avatar
    Join Date
    Nov 2004
    Location
    WNY
    Posts
    2,772
    Quote Originally Posted by pzr2874 View Post
    15 minute job at the most to do it yourself....
    +1.
    The first rule of the Faction is...DO NOT TALK ABOUT THE FACTION.
    NY GIANTS
    Hybrid Faction #19
    Blobeye Syndicate #19
    Mods

  6. #5
    Registered User WrecksWruthor's Avatar
    Join Date
    Feb 2008
    Location
    VA
    Posts
    36
    Quote Originally Posted by PRIMAJIN View Post
    I drive an 04 sti, i believe i have the same problem, code read was. P0171 system is too lean Bank 1. im understanding that i have to replace an 02 sensor, however im not sure witch one. Does anyone know how to find the o2 sensor that is bad, with the information that i gave ya. thanx fellas
    First off, this is a quick generic summary for that code:

    OBD-II Trouble Code: P0171 System Too Lean (Bank 1)

    According to that site, the issue is not the O2 sensor at all. It is probably a dirty MAF sensor creating a condition that triggered the code from the O2 sensor.

+ Reply to Thread

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself. We strongly suggest that you stay away from using aol, yahoo, msn, and hotmail accounts. Sometimes the mail server blocks the emails from our server. As a result you will not receive any notifications including the confirmation email.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •