Creaping boost in STI
Results 1 to 2 of 2

This is a discussion on Creaping boost in STI within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; Hi, I am wondering if it is normal for a 2001 v7 STi when boosting under a bit of load ...

  1. #1
    Registered User Rych's Avatar
    Join Date
    Aug 2008
    Location
    Auckland, New Zealand
    Posts
    7

    Creaping boost in STI

    Hi, I am wondering if it is normal for a 2001 v7 STi when boosting under a bit of load in 4th / 5th gear for it to creap up to 18 - 20 psi then onces it gets up to a good rpm for that gear it will drop back to its normal 15 - 16 psi. 1st 2nd and 3rd all go straight to about 15psi.

    It just seems to be if I put my foot down when the car is in slight too low revs for the gear it will creap right up to around 20 psi then drop back. Not sure if its a dodgy boost gauge or leak or if that's just normal for this car.

    Also when boosting in 4th / 5th gear with peddle only half on gas and going into boost, it the boost gauge seems to wobble up and down a little when I'm not under fool throttle.

    Help would be much appreciated cheers.

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User Timdog1650's Avatar
    Join Date
    Aug 2002
    Location
    Virginia Beach, VA
    Posts
    6,170
    There is a link in my signature explaining boost creep...that might help you narrow down some of the causes. What mods do you have done to the car? It might not be boost creep if you have a stock car.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •