Low boost only 5-6 psi problem
+ Reply to Thread
Results 1 to 5 of 5

This is a discussion on Low boost only 5-6 psi problem within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; Im having boost problems on my wrx,ive checked all pipes around turbo and boost solonoid,its drivin me crazy.can any body ...

  1. #1
    Registered User SILLYBILLYS WRX's Avatar
    Join Date
    Jul 2008
    Location
    UK
    Posts
    4

    Red face Low boost only 5-6 psi problem

    Im having boost problems on my wrx,ive checked all pipes around turbo and boost solonoid,its drivin me crazy.can any body help please.??

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Sammich Makin' Pwincess wrxtreme06's Avatar
    Join Date
    May 2007
    Location
    orlando flawduh
    Posts
    12,760
    I Support ClubWRX
    what modifications do you have

    desiree
    your friendly, neighborhood subaru girl
    abbigale : 06 impreza wrx tr: cobb stage II
    hawkeye alliance #11:11//
    wingl3ss @ll!ance #17 // lvl 80 N.E.R.D.

  4. #3
    Registered User SILLYBILLYS WRX's Avatar
    Join Date
    Jul 2008
    Location
    UK
    Posts
    4

    Boost problem

    I have no engine mods,standard .i changed to a 3port solonoid,i thought it was that.it may be that the boost pipes are in wrong position.?
    Last edited by SILLYBILLYS WRX; 07-28-2008 at 01:58 PM.

  5. #4
    The Default One SeattleJeremy's Avatar
    Join Date
    Jul 2004
    Location
    Seattle, WA
    Posts
    4,488
    If you don't have any engine mods, I'd suggest putting the stock boost solenoid back on .
    Then check the other lines.

  6. #5
    Registered User adizzle02's Avatar
    Join Date
    Mar 2008
    Location
    Sandy Utah
    Posts
    963
    Quote Originally Posted by SILLYBILLYS WRX View Post
    I have no engine mods,standard .i changed to a 3port solonoid,i thought it was that.it may be that the boost pipes are in wrong position.?
    im sure you may have seen this but its a good reference for where the hoses go for the stock bcs CobbTuning.com - How Subaruís Factory Boost Control System Works

    as suggested i would try putting the stock bcs back on and see if the problem goes away. I was having the same low boost problem with mine and it turned out that my stock bcs was bad.... it also wouldnt hurt to check out all the boost lines to make sure that there are no cracks or anything
    VF39'd and Clark Tuned
    BugEyeMafia #176
    Basshead Member #3

+ Reply to Thread

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself. We strongly suggest that you stay away from using aol, yahoo, msn, and hotmail accounts. Sometimes the mail server blocks the emails from our server. As a result you will not receive any notifications including the confirmation email.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •