Air Bag Light just came on?! Help please...
Results 1 to 11 of 11

This is a discussion on Air Bag Light just came on?! Help please... within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; 04 STi, 89000km, stock. After turning it on one day, my Air Bag Light was on?! I park in my ...

  1. #1
    Registered User ooWRXoo's Avatar
    Join Date
    Jul 2007
    Location
    Montreal
    Posts
    147

    Air Bag Light just came on?! Help please...

    04 STi, 89000km, stock.

    After turning it on one day, my Air Bag Light was on?!
    I park in my driveway behind my buddys jeep, so i doubt someone hit it. anyways...

    I brought it to the dealership and dude said it was my batterie that was dying that was making sensors act all weird.

    I have noticed that on damp (?if thats how u spell it) mornings she turns over a few times before actually running at idle while parked.

    2 Questions
    -Do you guys think it really is my batterie?
    Isnt there a low bat idiot light in dash?

    -Can the dealership run a scan to find an error code?
    Where can i check the results of this code?

    Any and all help will be greatly appreciated. Thx in advance.
    Black 2004 WRX STi - BlobEye Syndicate #200
    "As I walk through the valley of the shadow of death, I shall fear no EVO."
    I'm always looking for Subaru fanatics in the greater Montreal area. If your close, send me a pm.

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User ooWRXoo's Avatar
    Join Date
    Jul 2007
    Location
    Montreal
    Posts
    147
    come on guys, im stumped on this one...

    this weekend, ill be going to get the batterie.. so ill let you guys know whats happens after that...

    but has anyone heard of anything similar??
    Black 2004 WRX STi - BlobEye Syndicate #200
    "As I walk through the valley of the shadow of death, I shall fear no EVO."
    I'm always looking for Subaru fanatics in the greater Montreal area. If your close, send me a pm.

  4. #3
    Registered User davs11's Avatar
    Join Date
    Dec 2007
    Location
    Sudbury
    Posts
    48

    hey

    Hey man im having the exact same problem as you had.. im not sure if you figured it out or not but do you remember what the problem what?
    04 STI 80000Ks

    Quote Originally Posted by ooWRXoo View Post
    come on guys, im stumped on this one...

    this weekend, ill be going to get the batterie.. so ill let you guys know whats happens after that...

    but has anyone heard of anything similar??
    Black 2004 STi "Black Betty"

  5. #4
    Registered User Acrdys's Avatar
    Join Date
    Jun 2007
    Location
    Lemore
    Posts
    1,117
    mine went on when i installed my guages...

    I'm guessing the culprit is the clock, not shure trying to find some info on it.
    Hawk-Eye Alliance#8089
    MODS LIST

  6. #5
    Registered User 04 STi CLoNe's Avatar
    Join Date
    May 2008
    Location
    San Diego
    Posts
    24

    airbag light

    I have an 04 WRX 2.0 and my airbag light came on too at about 55000 miles sometimes it will turn off for a few days then comes back on?...

  7. #6
    The Default One SeattleJeremy's Avatar
    Join Date
    Jul 2004
    Location
    Seattle, WA
    Posts
    4,488
    If you still have the battery that came with the car from the factory, then I wouldn't be surprised if you do need a replacement.
    The stock Subaru batteries are not known for there high quality.

    Also, you can go to any shop to have it checked.

  8. #7
    Registered User dtwizy's Avatar
    Join Date
    May 2008
    Location
    Los Angeles
    Posts
    19
    dude this happened to me the other day too i went out for a drive and when i was on my way back home i noticed the airbag light was on while i was driving. when I got home i pulled out the owners manual and looked up the fuses...pulled out anything that had to do with the airbag but none of em were out. then i tried checking for troublecodes with my OBD II scanner but I got nothing.....after that i turned the car on and it turned off after 6 seconds like the manual says...the light hasnt turned back on since....the cars got about 47k miles on it

  9. #8
    Registered User WRXwagonMAFIA's Avatar
    Join Date
    Aug 2008
    Location
    some old backroad
    Posts
    123
    ive got about 70k on my 05', my airbag light is on probably 75% of the time. ive just learned to ignore it. i actually notice it more when it decides to go out for a couple days. ha. but no, the dealer, the shop, no one knows or could figure it out sinse about 50k. so i just ignore
    04' WRB wagon stage 2
    wagon Mafia #1 Where my wagons at?

  10. #9
    Registered User AMR93's Avatar
    Join Date
    Jul 2011
    Posts
    5
    i am having the same exact problem on my 04 STI with only 51,000 on it, the light just came on today after i got done washing her, i started her up and the air bag light was on

  11. #10
    Registered User
    Join Date
    Jul 2011
    Location
    P-Town California
    Posts
    10
    so just resetting your batterie doesn't work to reset your airbag light? hmm wierd it always works for me

  12. #11
    Registered User jgardiner's Avatar
    Join Date
    Oct 2010
    Location
    Calgary, Canada
    Posts
    316
    battery = one
    batteries = many

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •