New to WRX Need Help
+ Reply to Thread
Results 1 to 5 of 5

This is a discussion on New to WRX Need Help within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; Hey Guys, I just recently got my WRX, and im new to the turbo world and have a question. Now ...

  1. #1
    Registered User tooms789's Avatar
    Join Date
    Nov 2007
    Posts
    10

    New to WRX Need Help

    Hey Guys,
    I just recently got my WRX, and im new to the turbo world and have a question. Now before i get ragged on i did look through the search feature and looked manually for about 3 hours for answers (Found a lot Great Site!) But i have a FAQ i couldnt find my exact answer to. My 03 has;power enterprise 1820 turbo, aps dr550 front mount intercooler, power enterprise 650cc fuel injectors, 255lph walbro fuel pump, perrin fuel rails
    turbo xs cat-back exhaust, 3" stainless steel midpipe
    4" stainless steel downpipe, 3" stainless steel high flow cat
    perrin uppipe, turbo xs utech (not hooked up), turbo xs hp boost controller, hks turbo timer, turbo xs bov, aps cold air intake, perrin springs, kyb struts, rays engineering g-game 18X7.5, autometer gauges, seibon carbon fiber hood, tinted taillights.(Sorry for the long list) The problem im having is rough idle. Now like i said i looked through all the threads i could find for rough idle, BUT, i was wondering if anyone out there could give me anything to help me with my set up. Like every other thread the car goes from about 1k rpm to almost stall. And other than that the car runs great. Can anyone help with any kind of answer? I know i saw things about intakes causing it and vaccum lines, but honeslty im so much of a noob i have to go to a buddies house to find out where to check vaccum lines. But again, awesome site helped with a lot of questions i had.

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User tooms789's Avatar
    Join Date
    Nov 2007
    Posts
    10
    p.s. If this makes a difference. Also today it threw a CEL and i noticed in couple days ive had it every once in a while, ill get a pop from the exhaust, didnt know if it was due to running rich. Mostly accurs on downshifts, and after hard accelerations. And i had a mustang GT with straight pipes that popped but its not like a de-acceleration pop you hear on a lot of cars its almost like a backfire except quieter

  4. #3
    Registered User JETS02WRX's Avatar
    Join Date
    Oct 2004
    Location
    West Chester, Pa
    Posts
    68
    Quote Originally Posted by tooms789 View Post
    My 03 has;power enterprise 1820 turbo, aps dr550 front mount intercooler, power enterprise 650cc fuel injectors, 255lph walbro fuel pump, perrin fuel rails
    turbo xs cat-back exhaust, 3" stainless steel midpipe
    4" stainless steel downpipe, 3" stainless steel high flow cat
    perrin uppipe, turbo xs utech (not hooked up), turbo xs hp boost controller, hks turbo timer, turbo xs bov, aps cold air intake,
    I know what everyone is thinking..so i'll ask. WHY is the utec not hooked up. I'm not familiar with it, but I thought it was a 'piggy back' system and had to be hooked up in order for your car to run right. As far as your issues, it sounds like you have rich misfire. You should honestly stop driving your car and have it looked at by a tuner IMMEDIATELY. If you are driving the car and its running too rich, you will wash the cylinders of oil. This will ultimately lead to your cars demise.
    Ask the original owner what tune is on the ECU. Sounds like its tuned poorly.
    All in all you need someone with a wideband and a data logger in order to tell you whats going on. BE CAREFUL.
    Last edited by JETS02WRX; 07-18-2008 at 09:02 PM.
    02 MBP WRX Wagon
    INFO ABOUT THE WAGON

    06 WRB WRX Limited
    tristatetuners.com

  5. #4
    Registered User tooms789's Avatar
    Join Date
    Nov 2007
    Posts
    10
    Well the kid i bought it from said he had it in, but he took it to ESP a tuner in Sterling MA, and had them take it out and retune the car to get better gas mileage. Ive actually been looking around the area for a tuner to bring it to to get it back in and retuned.

  6. #5
    Registered User tooms789's Avatar
    Join Date
    Nov 2007
    Posts
    10
    also the CEL cleared itself yesterday. But i appreciate the reply, definitly gonna bring it to the tuner sooner then later now.

+ Reply to Thread

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself. We strongly suggest that you stay away from using aol, yahoo, msn, and hotmail accounts. Sometimes the mail server blocks the emails from our server. As a result you will not receive any notifications including the confirmation email.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •