WRX Missfiring
Results 1 to 5 of 5

This is a discussion on WRX Missfiring within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; I rebuilt my 2002 wrx and now when i run it, it is missfiring. I scanned it and i got ...

  1. #1
    Registered User
    Join Date
    Jul 2006
    Posts
    11

    WRX Missfiring

    I rebuilt my 2002 wrx and now when i run it, it is missfiring. I scanned it and i got P0301, P0302, P0304. SO i deleted the codes and scanned it again and i got P0301, P0302, P0303. I dont know why it is doing this. I am thinking it is my timing but i wanted some suggestions. Thank You.

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Moderator Donkey's Avatar
    Join Date
    Apr 2005
    Location
    Da boonies
    Posts
    6,150
    I Support ClubWRX
    Quote Originally Posted by smitt04 View Post
    I rebuilt my 2002 wrx and now when i run it, it is missfiring. I scanned it and i got P0301, P0302, P0304. SO i deleted the codes and scanned it again and i got P0301, P0302, P0303. I dont know why it is doing this. I am thinking it is my timing but i wanted some suggestions. Thank You.
    Jebus people.There needs to be a sticky on how to ask a technical question.
    1) Helps if you list all your mods
    2)Give a descriptive and detailed timeline of events
    IE: "It has done this since I bought the car"
    "I just installed an air intake and had no CEL originally when I started the car after the install.Now after 1hr of driving I have a CEL and the DTC # is P0xxx"

    Did you recheck to see if the timing marks line up?What plugs are you using and what gap?Also you cannot switch up the coil pack harness.The harness connections are specific to the cylinder.
    Resident Adviser @ WTF Tuning, LLC
    2002 FORESTER S
    1998 FORESTER S




  4. #3
    Registered User
    Join Date
    Jul 2006
    Posts
    11
    The only mod i have is a cold air intake. The whole problem happened when i blew a spark out of my head. I took of the head and sent it to a machine shop to get it fixed then i put my car all back together. As soon as i start my car i can tell it is not running on all 4 cylinders. The DTC codes are as i stated above.

  5. #4
    Registered User Timdog1650's Avatar
    Join Date
    Aug 2002
    Location
    Virginia Beach, VA
    Posts
    6,170
    Did you do any of the work or was it done for you? Did you do the motor job? Did you use the factory service manual for removing/reinstalling the heads?

  6. #5
    Moderator Donkey's Avatar
    Join Date
    Apr 2005
    Location
    Da boonies
    Posts
    6,150
    I Support ClubWRX
    Sounds like the cam timing is off.You will have to check to see if the cam gear timing marks line up when the #1 cylinder is at TDC.
    Resident Adviser @ WTF Tuning, LLC
    2002 FORESTER S
    1998 FORESTER S




Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •