Cigarette lighter fuse blew!
Results 1 to 7 of 7

This is a discussion on Cigarette lighter fuse blew! within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; anybody know how i can go about fixing this. Was an idiot and stuck in gauge wires to see it ...

  1. #1
    Registered User scoobe's Avatar
    Join Date
    Apr 2008
    Location
    Barrington IL
    Posts
    80

    Cigarette lighter fuse blew!

    anybody know how i can go about fixing this.

    Was an idiot and stuck in gauge wires to see it light up, it worked for 2 seconds then click and yeah.


    Any help would be appreciated

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User justin.jordan2's Avatar
    Join Date
    Feb 2008
    Location
    FAIRFIELD, CALIFORNIA
    Posts
    937
    Quote Originally Posted by scoobe View Post
    anybody know how i can go about fixing this.

    Was an idiot and stuck in gauge wires to see it light up, it worked for 2 seconds then click and yeah.


    Any help would be appreciated
    change the fuse. should be behind the lil glove box looking thing to the left of the steering wheel. pull it out fuses are behind it, look for the one that had blew out replace.
    COBB FLASHED STAGE 2, UPPIPE, DOWNPIPE WITH HIGH FLOW CAT, AND FULL 3 INCH CAT BACK, 160 CRUCIAL RACING THERMOSTAT, K&N FILTER. TRACK: 1/4 MILE 13.66 102.7 MPH ON THE COBB OTS MAP

  4. #3
    Registered User scoobe's Avatar
    Join Date
    Apr 2008
    Location
    Barrington IL
    Posts
    80
    i looked in there and didnt find a label for it. ill individually check them over

  5. #4
    Registered User peapod136's Avatar
    Join Date
    Aug 2008
    Location
    Oregon
    Posts
    6
    Same thing happened to me today! Not only is my cigarette lighter not work, but the heated seats and rear view mirror are also out!!! I've checked my fuses they all seem good, any other ideas i'd appreciate as well!

    Thanks!

  6. #5
    Registered User scoobe's Avatar
    Join Date
    Apr 2008
    Location
    Barrington IL
    Posts
    80
    Did you check the ones under the hood? The ones for the mirrors are next to your steering wheel on the left in a little compartment that you pull out.

  7. #6
    Registered User peapod136's Avatar
    Join Date
    Aug 2008
    Location
    Oregon
    Posts
    6
    yep, i've checked them all! i'm pullin my hair out with this though, the damn car isn't even a year old and ****'s breakin!!!! thank goodness for the warranty, it's going to the dealership tuesday, until then though radar detector for police will be down

  8. #7
    Registered User
    Join Date
    Dec 2008
    Posts
    1
    Yea, I just had the same thing happen to me. If you look above the fuse panel in the dash, you'll see a sticker that notes the heated seat fuse is located outside of the cluster to the right. Sure enough, it is. But mine isn't blown. Dammit. Wasn't easy to get to either.
    ----
    Found it- fuse #4 on my 05 labeled Power Mirror/Ciger. Of course, the spare 20amp fuse has already been used.
    Last edited by john.from.vt; 12-26-2008 at 02:49 PM. Reason: found the solution to my problem

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •