missfire
Results 1 to 3 of 3

This is a discussion on missfire within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; hi i am having a missfire in my oo wrx, problem started after refueling thought that maybe it was dirty ...

  1. #1
    Registered User
    Join Date
    Apr 2008
    Posts
    2

    Red face missfire

    hi i am having a missfire in my oo wrx, problem started after refueling thought that maybe it was dirty fuel, changed the filter which was very dirty , then checked inside the tank .
    only missfires under heavy load or at over 3500 revs, was going to change plugs but that is not that easy, do i need a special wrench , do i undo the 10mm bolt to remove the lead and plug , or is there another filter in the line after the main filter, can anyone help:

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User teflon_jones's Avatar
    Join Date
    Apr 2007
    Location
    8000' up in Colorado
    Posts
    6,753
    The basics of getting your questions answered:
    1. Provide your vehicle year and model
    2. Provide your mods
    3. Describe the problem in detail including when it started and any recent changes to the car

    Without doing this, nobody can accurately answer your questions.
    Scott
    Past Subies - '11 STI Limited stage 1+ and '04 STi stage 2+
    '13 Wrangler Rubicon - custom front bumper w/12k lb winch & off-road lights, skid plates, diff guards, etc.
    '04 Porsche 911 Turbo GT2 clone 600 HP/TQ
    '77 F-150 heavily modded for off-roading

  4. #3

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •