cruise control not working on 2002 wrx?
Results 1 to 5 of 5

This is a discussion on cruise control not working on 2002 wrx? within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; hi all- i have a 2002 wrx with 75,000 miles. recently, i noticed the cruise control was not working. the ...

  1. #1
    Registered User
    Join Date
    Dec 2007
    Posts
    5

    Question cruise control not working on 2002 wrx?

    hi all-

    i have a 2002 wrx with 75,000 miles. recently, i noticed the cruise control was not working. the light still comes on in the on/off switch on the panel when i push it on. i checked for a fuse and could not find one for cruise control in either fuse box.

    any other ideas to check before i take it to the dealer? any idea how much a replacement cruise control unit would cost if i need one?

    thanks!

    boochydog

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Geriatric Ginger Mod Rogan's Avatar
    Join Date
    May 2007
    Location
    behind the wheel
    Posts
    8,188
    I Support ClubWRX
    make sure the pedal switches are adjusted properly.

    done any work on the car recently? IF so, what/where?

    check fuse #6, and fuse #18
    Rogan o_0
    '96 Dodge 2500 CTD @ 40psi - over 700 lb/ft TQ, 7" stack, and 5speed! - SOLD
    '01 Dodge 2500 CTD 6-holed hand-shaker - 3850# dual disk - 900 lb/ft - SOLD
    '97 Dodge 3500 CTD DUALLY built Auto - 40psi boosties - 750 lb/ft

  4. #3
    Registered User
    Join Date
    Dec 2007
    Posts
    5
    i will go check those fuses. i had my 60,000 tuneup done at about 68,000 miles, but the cc worked after that. i believe i have had the 2004 recall work done for the cc clip.

    by pedal switches, do you mean the length of travel on the pedals when they are engaged?

  5. #4
    Geriatric Ginger Mod Rogan's Avatar
    Join Date
    May 2007
    Location
    behind the wheel
    Posts
    8,188
    I Support ClubWRX
    make sure the plungers are depressed when the pedals are up. you should be able to depress the pedals slightly, and hear a possible 'click' from the switch on the arm(s)
    Rogan o_0
    '96 Dodge 2500 CTD @ 40psi - over 700 lb/ft TQ, 7" stack, and 5speed! - SOLD
    '01 Dodge 2500 CTD 6-holed hand-shaker - 3850# dual disk - 900 lb/ft - SOLD
    '97 Dodge 3500 CTD DUALLY built Auto - 40psi boosties - 750 lb/ft

  6. #5
    Registered User
    Join Date
    Dec 2007
    Posts
    5
    checked fuses and pedals - all seems to be ok.

    any other suggestions?

    i just replaced the cabin filtration system filter - maybe that will help...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •