Car Revs high after start HELP!
Results 1 to 7 of 7

This is a discussion on Car Revs high after start HELP! within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; after an engine swap in my 2002 WRX my car just revs super high on start up. any input on ...

  1. #1
    Registered User
    Join Date
    Jun 2008
    Posts
    7

    Car Revs high after start HELP!

    after an engine swap in my 2002 WRX my car just revs super high on start up. any input on what the problem could be?

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User teflon_jones's Avatar
    Join Date
    Apr 2007
    Location
    8000' up in Colorado
    Posts
    6,753
    You don't provide enough info to go on. What exact setup did you put in the car? You need to list everything about your car and exactly what was modified including what tuning has been done to it.
    Scott
    Past Subies - '11 STI Limited stage 1+ and '04 STi stage 2+
    '13 Wrangler Rubicon - custom front bumper w/12k lb winch & off-road lights, skid plates, diff guards, etc.
    '04 Porsche 911 Turbo GT2 clone 600 HP/TQ
    '77 F-150 heavily modded for off-roading

  4. #3
    Registered User
    Join Date
    Jun 2008
    Posts
    7
    alright.
    its a 2002 Wrx ej20 with 560 injectors 225 LPF fuel pump.
    Agency 3 inch turbo inlet tube, CAI, greddy recirculating blowoff,
    port and polished intake manifold and heads. light weight crank pulley, full downpipe back BPM exhaust, HKS turbo timer and mishimoto 2 core radiator.

    Now on start up my throttle just jumps wide open, i am heading in the direction of the idel air control valve or the throttle position sensor. But it very well could be a vacuum leak or plug.

    Any other suggestions that i should maybe check or look into?

  5. #4
    Registered User
    Join Date
    Jun 2008
    Posts
    7
    also the car throws no codes

  6. #5
    Registered User teflon_jones's Avatar
    Join Date
    Apr 2007
    Location
    8000' up in Colorado
    Posts
    6,753
    Quote Originally Posted by Bobby5448 View Post
    Now on start up my throttle just jumps wide open, i am heading in the direction of the idel air control valve or the throttle position sensor. But it very well could be a vacuum leak or plug.
    Those all sound like possibilities. What kind of engine tuning are you running?
    Scott
    Past Subies - '11 STI Limited stage 1+ and '04 STi stage 2+
    '13 Wrangler Rubicon - custom front bumper w/12k lb winch & off-road lights, skid plates, diff guards, etc.
    '04 Porsche 911 Turbo GT2 clone 600 HP/TQ
    '77 F-150 heavily modded for off-roading

  7. #6
    Registered User
    Join Date
    Jun 2008
    Posts
    7
    Well to be honest, i am extremely new to tuning and have done nothing yet. If its possible to ask without being laughed at, i would like help with tuning and think it could help the problem.

    From ground 1- Where do i start?

  8. #7
    Registered User
    Join Date
    Jun 2008
    Posts
    7
    Ill try to be as specific as possible with what the car is actually doing.

    When i start the car it has a slow rising RPM level, I have never just let it run all the way up. I always just shut the car off.
    When i turn the key off i can hear the turbo spool down.
    I have no check engine light because i dont think it has actually ran long enough.

    on my intake manifold i have 2 vacuum line spots and dont know exactley where those 2 go

    The first one is on the front side of the manifold on the left side of the throttle body, it has a 90 degree bend going down
    and the second is on the back side of the manifold and it at the bottom right side of the throttle body. ( From front of car)

    help with those and where they go may be a first step. but i am pretty desperate.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •