Headers(manifold) PROBLEMS
+ Reply to Thread
Results 1 to 5 of 5

This is a discussion on Headers(manifold) PROBLEMS within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; Hi, i changed the headers/manifold and up pipe now my air/fuel ratio reding does not reach the ecu and my ...

  1. #1
    Registered User
    Join Date
    May 2008
    Posts
    6

    Headers(manifold) PROBLEMS

    Hi, i changed the headers/manifold and up pipe now my air/fuel ratio reding does not reach the ecu and my check engine light has come on. yet i have not removed any sensors.

    any coments
    STi 04, Turbosmart Supersonic Dump Valve, Turbosmart Boost Tee, FSE power boost valve, PSi3 Ecu Data Monitor, K&N Typhoon Filter, Charge Speed Carbon Fibre Hood with scoop, Charge Speed Carbon Fibre 3d Rear Spoiler. V2 3" DE-CAT Exhaust system (Straight Through), GT Spec Manifold. (+ I'm the dealer for Turbosmart, PSi3, and Charge Speed )

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User justin.jordan2's Avatar
    Join Date
    Feb 2008
    Location
    FAIRFIELD, CALIFORNIA
    Posts
    937
    Quote Originally Posted by chinaa108 View Post
    Hi, i changed the headers/manifold and up pipe now my air/fuel ratio reding does not reach the ecu and my check engine light has come on. yet i have not removed any sensors.

    any coments
    well i dont know bout you but if i remember correctly i had one sensors in the uppipe and an 02 sensor somewhere cant remember though.
    COBB FLASHED STAGE 2, UPPIPE, DOWNPIPE WITH HIGH FLOW CAT, AND FULL 3 INCH CAT BACK, 160 CRUCIAL RACING THERMOSTAT, K&N FILTER. TRACK: 1/4 MILE 13.66 102.7 MPH ON THE COBB OTS MAP

  4. #3

  5. #4
    Registered User
    Join Date
    May 2008
    Posts
    6
    The check engine light is on and the code is P0031
    STi 04, Turbosmart Supersonic Dump Valve, Turbosmart Boost Tee, FSE power boost valve, PSi3 Ecu Data Monitor, K&N Typhoon Filter, Charge Speed Carbon Fibre Hood with scoop, Charge Speed Carbon Fibre 3d Rear Spoiler. V2 3" DE-CAT Exhaust system (Straight Through), GT Spec Manifold. (+ I'm the dealer for Turbosmart, PSi3, and Charge Speed )

  6. #5
    Registered User Timdog1650's Avatar
    Join Date
    Aug 2002
    Location
    Virginia Beach, VA
    Posts
    6,170
    p0031 = Front O2 sensor input low. I forget if the front O2 sensor is in the manifold or the uppipe...think it's in the manifold. Make sure it's connected to the harness properly and is threaded/torqued into the manifold all the way. Reset the ECU. See if the code comes back on. If it does, you probably damaged the sensor or the harness. It would be about $100 to replace the sensor if it was shot. Make sure all the wiring/harness is secured properly. You might get that code if you had melted the sensor wires on the header pipes and caused them to short out (which would be bad).

    Just double check everything and make sure it's connected...then replace. That would be my plan of attack.

+ Reply to Thread

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself. We strongly suggest that you stay away from using aol, yahoo, msn, and hotmail accounts. Sometimes the mail server blocks the emails from our server. As a result you will not receive any notifications including the confirmation email.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •