electrical problem
Results 1 to 3 of 3

This is a discussion on electrical problem within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; So i just got my 6sp back into my 2002 WRX. a few miles down the road, fuse #18 blew. ...

  1. #1
    Registered User efmd3's Avatar
    Join Date
    Jun 2006
    Location
    the ham
    Posts
    9,156

    electrical problem

    So i just got my 6sp back into my 2002 WRX.

    a few miles down the road, fuse #18 blew.
    I replaced the fuse and it blew in the exact same place on the road that it blew the first time (i got there sooner this time).

    where might the short be? this circuit has the VSS, head light, high beam, drl, abs solenoid, etc on it.

    PS did not do any wire hacking to install the 6sp.

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    He simply abides. SD_GR's Avatar
    Join Date
    Jul 2002
    Location
    CA, US
    Posts
    21,889
    I Support ClubWRX
    Wild guess, but check the clips to the gearbox itself. Isn't there also a ground strap to the gearbox from the top? Did you get DCDD working -- what about that?
    WRX Info Links, Courtesy TheJ
    The world breaks everyone and afterward many are strong in the broken places. Ernest Hemingway
    I lied. I cheated. I bribed men to cover the crimes of other men. I am an accessory to murder. But the most damning thing of all... I think I can live with it. And if I had to do it all over again - I would. Benjamin Sisko
    DISCLAIMER: Opinions expressed are the author's alone and are inherently worthless.

  4. #3
    Registered User efmd3's Avatar
    Join Date
    Jun 2006
    Location
    the ham
    Posts
    9,156
    Quote Originally Posted by SD_GR View Post
    Wild guess, but check the clips to the gearbox itself. Isn't there also a ground strap to the gearbox from the top? Did you get DCDD working -- what about that?
    AFAIK the clips are all very secure and the ground strap is snug when i tugged on it. I'll be removing the intercooler in a bit to see whats going on.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •